Discussion Board

Results 1 to 3 of 3

Hybrid View

  1. #1
    Registered User
    Join Date
    Nov 2011

    QA fails for web app saying "There is no information displayed in the application"

    I developed a simple web app using Nokia Web Developer Environment. The app worked well when I ran it in the emulator present in the WDE. To be sure I even checked it in the "Nokia SDK 1.0 for Java Emulator" and it worked perfectly well. But on publishing the QA is always failing saying that "There is no information displayed in the application". I don't have any real device hence I have to depend on the emulator to test. Is there any other step I should take to make sure that it get published properly ?

  2. #2
    Registered User
    Join Date
    Jun 2008
    Port Elizabeth, South Africa

    Re: QA fails for web app saying "There is no information displayed in the application


    From personal experience: you have to verify that your application runs on an actual device.
    The simulator does not get all aspects of an actual device correct and it often has differences in rendering and code handling.

    When I create an application I run it in the simulator in "Local Preview" in order to debug the javascript then in "Cloud Preview" to get a better idea of how it will work on an actual device, then on a physical device in order to verify that the screen output is what I expected. I never expect the "Cloud Preview" to be perfect.

    The simulator's web browser seems to be far more full featured than the Nokia Browser and some DOM manipulations will work in the simulator, but won't in the Nokia Browser.

    The simulator also cannot handle some of the widget object code such as preferences storage for example (when running locally). So, you have to test some of the more advanced code on an actual device.

    I have not tried running the Java SDK's simulator to see how well it does with emulating the look and feel of an actual device with the Nokia Browser. I would have hoped that it would work, but your experience says otherwise.

    You could post the goo.gl link that gets created when you "Deploy Web App" for anyone with some spare time to run your application and report back with their tests. Maybe this will be enough for you to figure out what is going wrong.

    Last edited by sperelson; 2012-01-25 at 16:58.

  3. #3
    Nokia Developer Champion
    Join Date
    Oct 2010

    Re: QA fails for web app saying "There is no information displayed in the application

    Not sure if this helps, but if i still remember correcly this happened to me publishing my first web app... Check your config.xml if all data is properly filled out like <description> etc... </description> etc...

Similar Threads

  1. "Authorization failed" message displayed when installing jar file
    By capricious28 in forum Mobile Java General
    Replies: 10
    Last Post: 2014-07-04, 11:22
  2. Replies: 20
    Last Post: 2011-11-11, 13:13
  3. Replies: 18
    Last Post: 2011-11-08, 11:46
  4. Nokia 6275: Fail to use PC Suite's "Messaging" and "Application Installation"
    By Oro in forum PC Suite API and PC Connectivity SDK
    Replies: 3
    Last Post: 2007-09-26, 11:28
  5. Installation of "MyApp.jad" not supported error displayed
    By ashishga in forum Mobile Java General
    Replies: 7
    Last Post: 2006-12-11, 20:26

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts