×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    Jan 2012
    Posts
    5

    NFC for Nokia_Symbian_Belle_SDK_v0.6

    Thread [1] discusses and shows a link [search "Download the plug-in" in a post by Ron Liechty] to an NFC plugin for the Symbian_3_SDK_v1_0. That plugin won't install with Nokia_Symbian_Belle_SDK_v0.6.

    Nokia_Symbian_Belle_SDK_v0.6 doesn't come, as well, with the file jsr257.jar, ie, the packages com.nokia.nfc.*.

    So the question: Is there an equivalent NFC plugin for the Nokia_Symbian_Belle_SDK_v0.6? Or any work-arounds with that old plugin?



    [1] http://www.developer.nokia.com/Commu...-1.0-available
    Last edited by tinga; 2012-01-31 at 13:44. Reason: clarifying english

  2. #2
    Super Contributor
    Join Date
    Mar 2008
    Posts
    1,481

    Re: NFC for Nokia_Symbian_Belle_SDK_v0.6

    Hi,

    Are you developing J2ME app or Symbian app? I think the plugin are not necessary anymore as SDK contains all the binary/header files.

    Edit: there is no plugin for Belle 0.6,
    Last edited by mahbub_s60; 2012-02-06 at 15:19.

  3. #3
    Registered User
    Join Date
    Jan 2012
    Posts
    5

    Re: NFC for Nokia_Symbian_Belle_SDK_v0.6

    mahbub_s60: inside the lib dir of the package Nokia_Symbian_Belle_SDK_v0.6 there is no jsr257.jar. I extracted all jar files distributed along Nokia_Symbian_Belle_SDK_v0.6, and couldn't find any .class file containning nfc (neither, let's say ndef). So I don't believe jsr-257 support is included, *although*, under its docs/javadocs, documentation is provided. So the suspicion: has jsr257 been forgotten by mistaken?

  4. #4
    Super Contributor
    Join Date
    Mar 2008
    Posts
    1,481

    Re: NFC for Nokia_Symbian_Belle_SDK_v0.6

    Hi,
    Your finding is correct, see my previous msg. I meant Symbian/Qt plugins are not necessary (sorry for the mixed up)

    But I heard that for contactless API for Java there is no support in Belle release. Release from previous SDK (Symbian^3/Anna) should work with Belle (this is as far as I know, I have not tested or used it lately)
    Hope this explain.

Similar Threads

  1. Carbide version for Nokia_Symbian_Belle_SDK_v0.6
    By pranawcs in forum General Development Questions
    Replies: 4
    Last Post: 2011-10-12, 06:05

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×