×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    Jan 2012
    Posts
    5

    Question Application shortcut not appearing

    I'm puzzled, my app doesn't show up on the device menu. I've made own uri scheme handler, and by using that does open my app.

    This is myapp_harmattan.desktop file placed in /usr/share/applications:

    [Desktop Entry]
    Encoding=UTF-8
    Version=1.0
    Type=Application
    Terminal=false
    Name=myApp
    Exec=/usr/bin/invoker --single-instance --type=d -s /opt/myapp/bin/myapp
    Icon=/usr/share/icons/hicolor/80x80/apps/myapp80.png
    X-Window-Icon=
    X-HildonDesk-ShowInToolbar=true
    X-Osso-Type=application/x-executable
    MimeType=x-maemo-urischeme/myapp

    What gives?

  2. #2
    Nokia Developer Champion
    Join Date
    Jun 2008
    Location
    Noida,India
    Posts
    4,086

    Re: Application shortcut not appearing

    Though its about executable, try changing the path to this: Exec=/usr/bin/single-instance /opt/myapp/bin/myapp , Also verify if the icon is actually there at that path(/usr/share/icons/hicolor/80x80/apps/myapp80.png)

  3. #3
    Registered User
    Join Date
    Mar 2003
    Posts
    10

    Re: Application shortcut not appearing

    Do not modify your .desktop file outside of Qt Creator. And make sure it does not have utf8+bom encoding. It should be utf8 only.

    If it still not working, try to create a new project and copy your old images, scripts and qml files under appropriate folders. Use newly created .desktop file.

  4. #4
    Registered User
    Join Date
    Jan 2012
    Posts
    5

    Re: Application shortcut not appearing

    Problem solved, it was missing ;
    :P

Similar Threads

  1. Network status screens appearing behing application on E61
    By barnabyg in forum Mobile Java General
    Replies: 3
    Last Post: 2006-06-27, 18:54
  2. Dialog not appearing in Background Application.
    By kiranpuranik in forum Symbian
    Replies: 1
    Last Post: 2004-10-14, 06:34
  3. Application Icon not appearing in Emulator
    By amitaggarwal in forum Symbian
    Replies: 14
    Last Post: 2004-09-17, 07:58
  4. Application not appearing in emulator
    By Juggle4Evr1 in forum Symbian Tools & SDKs
    Replies: 2
    Last Post: 2003-05-19, 06:51

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×