Hi I usually develop for Symbian S60_3rd ed

If I want develop on S60 5th and Symbian 3^, how to do that?
Can I use my code on Symbian 3rd ed with some tweak or addition?

I must use newer SDK? How about Carbide?
Must use Qt? Or use Symbian c++ still possible?

I want to expand my app so not limited on Symbian S60_3rd only

Any documentation, or link, or reading that I can start learn about this topic?


Thanks a lot