×

Discussion Board

Results 1 to 2 of 2
  1. #1
    Nokia Developer Champion
    Join Date
    Apr 2005
    Location
    Boston
    Posts
    517

    URL opening changed behaviour with Symbian Belle ?!

    Ciao,

    I am seeing a problem with opening urls in on button press with Symbian Belle.
    For example:

    on (press) {
    getURL("http://m.facebook.com/sharer.php?u=http://www.domain.com&t=Ciao");
    }


    on (press) {
    getURL("http://mobile.twitter.com/home?status=Ciao http://www.domain.com");
    }


    Looks like that opening URLs which contain another usl as part of the message creates an issue. The browser opens and than is set to the background. It never goes to the original link but it goes to the default hompage of the browser settings.

    Is anyone seeing this issue?

    Alessandro

  2. #2
    Nokia Developer Champion
    Join Date
    Feb 2011
    Location
    bucharest
    Posts
    149

    Re: URL opening changed behaviour with Symbian Belle ?!

    got no problem with it... at least links to ovi (got links to my paid apps in flash under WRT)

    maybe you don't use WRT

    try escape the /, or just go with: something linke this:
    Code:
    on (press) {
    getURL("http://m.facebook.com/sharer.php?u=www.domain.com&t=Ciao");
    }
    seams that facebook doesn't upset omitting the http://, probably works with twitter too

Similar Threads

  1. Replies: 2
    Last Post: 2012-01-12, 13:33
  2. Why called Symbian Anna, Symbian Belle?
    By patrickz in forum Symbian
    Replies: 7
    Last Post: 2011-08-25, 11:03

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×