×

Discussion Board

Results 1 to 8 of 8
  1. #1
    Registered User
    Join Date
    Jan 2012
    Location
    Denmark
    Posts
    9

    [solved] Black screen when started from launcher

    Hi

    I have a wierd problem.

    My qml applications run fine on the simulator, in developer mode on the device and from the terminal, but whenever I try to start it using the icon on the desktop all I get is a blank screen

    I have tested with several applications, and always gets the same result.

    Any idea what I'm doing wrong.

    I'm using Qt Creator under SDK 1.2.

    Kim
    Last edited by KimF; 2012-02-22 at 19:42. Reason: Problem solved

  2. #2
    Nokia Developer Champion
    Join Date
    Jun 2008
    Location
    Noida,India
    Posts
    3,956

    Re: Black screen when started from launcher

    What is happening in the initial view/main of your app?

  3. #3
    Registered User
    Join Date
    Jul 2004
    Posts
    166

    Re: Black screen when started from launcher

    looks like its not able to find QML or some error in QML, I generally face same problem when QML has some issue. Did you tried running from Qt Creator ? Does is show some warning message ?
    http://kunalmaemo.blogspot.com/

  4. #4
    Registered User
    Join Date
    Mar 2003
    Posts
    10

    Exclamation Re: Black screen when started from launcher

    Make sure you've selected com.nokia.extras platform on Application tab, for Harmattan, not Symbian. (It's Symbian on attached picture, but should be Harmattan)


  5. #5
    Registered User
    Join Date
    Jan 2012
    Location
    Denmark
    Posts
    9

    Re: Black screen when started from launcher

    Hi

    Thanks for your answers, unfortunately it seemes as if I haven't been precise enough in my description, so I'll try again.

    If I, from the creator, run my applications in the Qt simulator, the program runs fine.

    If I, from the creator, run my applications on the device (N9, PR1.1), the program runs fine.

    If I deploy to the device, and start from the icon, I get a black screen, no errors.

    If I deploy to the device, and start from a command line, the program runs fine.

    To me it very much looks as the problem mentioned here Black screen on PR1.0, but on PR1.1.

    It is the same with every application I have compiled, Qt programs downloaded from nokia store does not have this problem.

    Kim

  6. #6
    Registered User
    Join Date
    Jan 2012
    Location
    Denmark
    Posts
    9

    Re: Black screen when started from launcher

    Hi again

    After a lot of testing, I have found the problem, it resides in the following line :

    viewer.setMainQmlFile(QLatin1String("qml/TE/main.qml"));

    If I change it to /opt/TE/qml/TE/main.qml, then the program runs from the launcher, but NOT in the simulator, debugger or from command line !

    What should the path be to work under both the simulator and the launcher ?

    Where do you put your qml files ?

    Kim

  7. #7
    Registered User
    Join Date
    Jul 2004
    Posts
    166

    Re: Black screen when started from launcher

    I generally load qml file from Qt Resource file, that way we can make sure that file are always present when application is installed and we always knows it location.
    like
    view.setSource(QUrl("qrc:/main.qml"));

    you will also need to create Qt resource file and add entry for all QML file and other resource like image.
    http://kunalmaemo.blogspot.com/

  8. #8
    Registered User
    Join Date
    Jan 2012
    Location
    Denmark
    Posts
    9

    Re: Black screen when started from launcher

    Thanks a lot, that's what I needed !

    Kim

Similar Threads

  1. RDA N900 in black screen.
    By jkosonen in forum [Archived] Qt Quick
    Replies: 1
    Last Post: 2011-02-08, 22:12
  2. 6220c Black Screen Problem?
    By RyanB2804 in forum Symbian
    Replies: 1
    Last Post: 2009-12-07, 09:59
  3. Replies: 5
    Last Post: 2009-09-11, 09:35
  4. 7650 after few secs, screen goes black
    By FatalError in forum Mobile Java General
    Replies: 1
    Last Post: 2003-06-26, 10:30

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •