×

Discussion Board

Results 1 to 2 of 2
  1. #1
    Registered User
    Join Date
    Jun 2011
    Posts
    16

    Running Opengl demo on device

    Hi

    I have created a small demo for Symbian^3 that uses OpenGL ES 2.0 via QGLFunctions, but it is not compiling for the device (C7 and N8). It runs fine on the desktop, though (but it is not a target platform).

    The problem is that the compiler is not able to find QGLFunctions, i.e.
    C:/QtGL/QtGL/glwindow.h:23: fatal error: QTOpengl/QGLFunctions: No such file or directory
    compilation terminated.
    Is the QGLFunctions module supported for Symbian^3 devices, or should I revert back to QtOpenGL only? If yes, how can I install Qt 4.8 on device so that I am able to run my code?

    p.s. I am aware of the smartinstaller option, and I am including it in my project settings, but it is useless if the code can't compile for the device.

    Also, I am adding
    Code:
    INCLUDEPATH += C:\QtSDK\Symbian\SDKs\Symbian3Qt473\epoc32\include
    in the Symbian {} part in my .pro file, but seems like QGLFunctions is not in the directory. (Is there something like Symbian3Qt480 etc?)

  2. #2
    Nokia Developer Expert
    Join Date
    Oct 2007
    Posts
    441

    Re: Running Opengl demo on device

    Hi

    indeed Qt 4.8 with mentioned QGLFunctions is not available for device targets in the latest Qt SDK 1.2 --- only desktop target is available. They say about it in the documentation ---

    As for deploying application dependencies and upgrading them on device , Smart Installer is the best option.

    INCLUDEPATH += C:\QtSDK\Symbian\SDKs\Symbian3Qt473\epoc32\include ---- absolute paths in configurations is not good for the project environment setup, even if that instruction is harmless to the project, it does not make the project profile look good. Please follow add-on documentations when you need to add correspondent specific instruction to the project profile.

Similar Threads

  1. Replies: 0
    Last Post: 2010-04-01, 05:56
  2. error running PDAP Demo from wtk on N72
    By galaxy_j2me in forum Mobile Java Networking & Messaging & Security
    Replies: 3
    Last Post: 2009-07-08, 12:15
  3. S60_3rd_FP1 installed, but failed running helloworldbasic demo.
    By sharpblade in forum Symbian Tools & SDKs
    Replies: 4
    Last Post: 2009-04-25, 10:50
  4. running OpenGL ES in N93
    By derBertl in forum Symbian Media (Closed)
    Replies: 3
    Last Post: 2006-10-10, 14:50
  5. Help Running the OpenGL examples (3rd ed.)
    By fabiano_pmj in forum Symbian
    Replies: 6
    Last Post: 2006-04-05, 09:50

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×