×

Discussion Board

Results 1 to 5 of 5
  1. #1
    Regular Contributor
    Join Date
    Sep 2010
    Posts
    65

    No including smartinstaller for Belle devices?

    Hello there,

    Read something like this over here:
    "Moreover, Symbian Belle devices have Qt in ROM and it is not intended to be updated by applications via Smart Installer but only when user does device firmware upgrade via Ovi Suite or over-the-air."

    So, aren't we supposed to include smart-installer in our Qt apps for the Symbian Belle devices or, am I getting it wrong?

  2. #2
    Super Contributor
    Join Date
    Jun 2006
    Location
    India
    Posts
    3,037

    Re: No including smartinstaller for Belle devices?

    Sorry, I did not find any link on here:
    Use [URL="http://qt.nokia.com/products/qt-quick/"]Qt-Quick[/URL] to make your application UI more attractive.

    [URL="http://store.ovi.com/content/271896"]http://store.ovi.com/content/271896[/URL] | [URL="http://store.ovi.com/content/276199"]http://store.ovi.com/content/276199[/URL] |[URL="http://store.ovi.com/content/276202"] http://store.ovi.com/content/276202[/URL] | [URL="http://store.ovi.com/content/280827"]http://store.ovi.com/content/280827[/URL]

  3. #3
    Regular Contributor
    Join Date
    Sep 2010
    Posts
    65

    Re: No including smartinstaller for Belle devices?


  4. #4
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: No including smartinstaller for Belle devices?

    While Qt is not updateable, other components may be missing (e.g. Notification API, In-App Purchase) or may be updateable, and therefore the smart installer can and in some cases must still be used. It will simply not have anything to do for Qt in particular, but since I'm asuming you make the same app available to Symbian Anna and Symbian^3 devices, having the SI is even more important.

    To keep things simple, Nokia Publish mandates that you deliver a SI wrapped package, even if maybe your application does not really need it in a particular case.
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  5. #5
    Regular Contributor
    Join Date
    Sep 2010
    Posts
    65

    Re: No including smartinstaller for Belle devices?

    Thanks for the clarification Itomuta! That was a good piece of information.

Similar Threads

  1. Replies: 3
    Last Post: 2012-01-09, 08:38
  2. Belle firmware for older devices
    By pippo2010 in forum Publishing to Nokia Store
    Replies: 5
    Last Post: 2011-12-10, 09:41

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×