×

Discussion Board

Results 1 to 7 of 7
  1. #1
    Registered User
    Join Date
    Oct 2010
    Posts
    15

    Angry MFeedback doesn't working

    Hi, for all! When i'm trying get vibration feedback with MFeedback in MApplication application working without errors, but I haven't vibration...

    Vibration feedback working only with QFeedbackHapticsEffect class, but it not working in daemon apps...

    How I can get vibraion in my daemon? Help me please!

  2. #2
    Registered User
    Join Date
    Aug 2008
    Posts
    5

    Re: MFeedback doesn't working

    It seems that feedback do not work on Non-GUI app.
    I replace QCoreApplication with QApplication in main function,it works

  3. #3
    Registered User
    Join Date
    Oct 2010
    Posts
    15

    Re: MFeedback doesn't working

    What feedback API are you using? MFeedback or QHapticsFeedbackEffect from QtMobility? If use haptics from Qt it's working good, but if you try using MFeedback API from libmeegotouch (QFeedback meegos plugin based in MFeedback)it didn't work... If you have sample, give me please =)

  4. #4
    Registered User
    Join Date
    Aug 2008
    Posts
    5

    Re: MFeedback doesn't working

    I tried MFeedback but failed. So i use QHapticsFeedbackEffect in my daemon apps,it works

  5. #5
    Registered User
    Join Date
    Oct 2010
    Posts
    15

    Re: MFeedback doesn't working

    So, right... Are you using haptics effect in daemos with root privileges? When i'm trying start daemon from root QApplication and MApplication doesn't working! App cannot connect to theme server, and in QCoreApplication haprics effect not working....

    this solution is working only with user privileges ... But not all tasks solving without root ... What approach are you using for creating daemons?

  6. #6
    Nokia Developer Moderator
    Join Date
    Mar 2009
    Posts
    1,024

    Re: MFeedback doesn't working

    Please note that a a daemon can run with user privilegies too.
    This is well documented at this page: http://harmattan-dev.nokia.com/docs/...g_daemons.html
    Thanks to aegis (yes this time it helps ) you can provide capabilities you need to your daemon which usually don't belong to processes which run as user.
    For that you just need to set the right tokens in the manifest file.

  7. #7
    Registered User
    Join Date
    Oct 2010
    Posts
    15

    Re: MFeedback doesn't working

    For root privilegies gui apps not working, because it cannot connect to theme server

Similar Threads

  1. Bluetooth connection working in emulator, but not working on Nokia E52
    By voroske.julia in forum Mobile Java Networking & Messaging & Security
    Replies: 3
    Last Post: 2011-05-30, 13:01
  2. WebPost not working on device, working fine on emulator
    By swarupk2007 in forum Symbian Networking & Messaging (Closed)
    Replies: 2
    Last Post: 2010-02-09, 14:59
  3. Replies: 2
    Last Post: 2009-07-24, 06:04
  4. Replies: 2
    Last Post: 2006-03-11, 09:29

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •