×

Discussion Board

Page 2 of 4 FirstFirst 1234 LastLast
Results 16 to 30 of 54
  1. #16
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,167

    Re: "unable to install" on device

    Then make sure you do have the camera wrapper installed, as well as the libC as well.

  2. #17
    Registered User
    Join Date
    Sep 2011
    Posts
    203

    Re: "unable to install" on device

    yes i am installing camerawrapper. also in Post #1 i copied .pkg.
    and as i mentioned earlier app is working in other devices, i am facing problem only in this device E52.

  3. #18
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,167

    Re: "unable to install" on device

    And that could indeed be because it does not have open-C libraries, thus do install them and try if it helps. Other devices might have gotten the library with Qt dependencies etc. or they might have been there already in firmware.

  4. #19
    Registered User
    Join Date
    Sep 2011
    Posts
    203

    Re: "unable to install" on device

    ok thank you. can you please tel me how to install them?

  5. #20
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,167

    Re: "unable to install" on device

    if you want to deploy the application through Nokia store, you would need to use Smart instaleler for the Open-C deployment in there, since these libraries are also Qt dependencies: http://www.developer.nokia.com/Commu...er_for_Symbian

    So you could basically check the QtSDK get the libraries from there for testing & development time, and then use the Smart installer for the actual release.

  6. #21
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,672

    Re: "unable to install" on device

    From the Open C/C++ plug-in pack. It is probably present on your hard drive, otherwise the code could not compile. The files in C:\Symbian\9.2\S60_3rd_FP1\nokia_plugin\openc\s60opencsis and C:\Symbian\9.2\S60_3rd_FP1\nokia_plugin\opencpp\s60opencppsis
    The download would be Resources above, Tools and downloads, Find more tools, Tools for Symbian C++ development. However the link is broken right now.

  7. #22
    Registered User
    Join Date
    Sep 2011
    Posts
    203

    Re: "unable to install" on device

    but i am using SDK 3rd FP1 and in this one Qt is not supported right?

    Edit:
    sorry i dint saw wizard_hu post.
    yes i have some sis files in the below mentioned link.
    i have to install all of them on device?

  8. #23
    Nokia Developer Champion
    Join Date
    Jun 2008
    Location
    Noida,India
    Posts
    3,987

    Re: "unable to install" on device

    Though the binary made from FP1 SDK should work on FP2 device as well, but can it be an issue here(as E52 is an FP2 device), btw on which other devices are you testing.

  9. #24
    Registered User
    Join Date
    Sep 2011
    Posts
    203

    Re: "unable to install" on device

    c5,5233 and n79

  10. #25
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,167

    Re: "unable to install" on device

    You should not mix the Smart Installer support, Qt general support & Nokia Store support for Qt, anyway the E52 is also on the list for Store: http://www.developer.nokia.com/Distr..._signing.xhtml

  11. #26
    Registered User
    Join Date
    Sep 2011
    Posts
    203

    Re: "unable to install" on device

    Thank you all. as mentioned by Wizard_hu sir I installed all the sis files which are in these folders
    C:\Symbian\9.2\S60_3rd_FP1\nokia_plugin\openc\s60opencsis and C:\Symbian\9.2\S60_3rd_FP1\nokia_plugin\opencpp\s60opencppsis
    and app is installing and working.....

  12. #27
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,167

    Re: "unable to install" on device

    Good to hear that it works. Anyway just repeating , so you won't get surprised. In case you want to distribute the application through Nokia Store, then you must use Smart Installer for the Open-C dependency handling, you can not embed it. And even if you don't use Nokia Store, you should still use Smart Installer. This is due the fact that Smart installer has build in logic to select the correct Open-C and other required dependencies it might need, and the selection is done according to platform version as well as firmware version, so different devices, might get different versions of the libraries.

  13. #28
    Registered User
    Join Date
    Sep 2011
    Posts
    203

    Re: "unable to install" on device

    ok thank you i'll keep this in mind.
    and i have one more doubt as i am embedding ZxingbarCodeReader, jar and exe in Software installer

    I have modified Some logic in ZXingBarcodeReader so i have to get this Symbian signed separately and then embed it in Installer and again i have to apply Symbian signed for Software Installer?

    SoftwareInstaller_EKA2.pkg
    Code:
    ; Installation file for Symbian OS 9.x for generic console application
    ; Installation file for SoftwareInstaller EXE
    ;
    ; This is an auto-generated PKG file by Carbide.
    ; This file uses variables specific to Carbide builds that will not work
    ; on command-line builds. If you want to use this generated PKG file from the
    ; command-line tools you will need to modify the variables with the appropriate
    ; values: $(EPOCROOT), $(PLATFORM), $(TARGET)
    ;
    ;
    ; UID is the exe's UID
    ;
    ;0xEDC63187
    #{"SoftwareInstaller EXE"},(0x20060A5B),1,0,0     
    
    ;Localised Vendor name
    %{"Vendor-EN"}
    
    ;Unique Vendor name
    :"Vendor"
    
    ;Supports S60 3rd&5rd Editions
    [0x101F7961], 0, 0, 0, {"S60 3rd Edition"}
    [0x102032BE], 0, 0, 0, {"S60 3rd Edition, FP1"}
    [0x102752AE], 0, 0, 0, {"S60 3rd Edition, FP2"}
    [0x1028315F], 0, 0, 0, {"S60 5th Edition"}
    
    ;Files to be installed	
    "..\data\App.jar"	- "d:\WidgetInstaller\App.jar"
    
    ;Installer files
    "..\data\WidgetInstFile"					  -"d:\WidgetInstaller\WidgetInstFile"
    "$(EPOCROOT)Epoc32\data\20060A5B.rsc"                             -"c:\private\101f875a\import\[20060A5B].rsc"
    "$(EPOCROOT)Epoc32\release\$(PLATFORM)\$(TARGET)\SoftwareInstaller.exe"		  -"!:\sys\bin\SoftwareInstaller.exe", FR,RI
    "$(EPOCROOT)Epoc32\release\$(PLATFORM)\$(TARGET)\Sample.exe"		  -"!:\sys\bin\Sample.exe",FR,RI
    
    ;ZXingBarcodeReader and CameraWrapper
    @"$(EPOCROOT)Epoc32\InstallToDevice\Sample\sis\ZXingBarcodeReader_S60.sisx", (0x20060D8F)
    
    ;CameraWrapper
    ;@"$(EPOCROOT)Epoc32\InstallToDevice\CameraWrapper\sis\camerawrapper.sisx", (0x2001ec5f)
    Last edited by please_help; 2012-03-08 at 05:42.

  14. #29
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,167

    Re: "unable to install" on device

    Basically the general rule is simple, you need to sign each installation packet you make, since you can not get the installer in device to accept any unsigned packages.

  15. #30
    Registered User
    Join Date
    Sep 2011
    Posts
    203

    Re: "unable to install" on device

    As I alredy asked in this Thread....
    http://www.developer.nokia.com/Commu...rtified-Signed
    I have lot of Confusions about signing ZXingBarCodeReader which also contains embeded CameraWrapper.sis
    and in that link post #4 wizad_hu mentioned
    The CameraWrapper is signed already, you can not (and should not) sign it for yourself.

Similar Threads

  1. Replies: 3
    Last Post: 2009-07-01, 14:30
  2. Replies: 1
    Last Post: 2009-02-04, 22:50
  3. Replies: 0
    Last Post: 2008-02-14, 10:27
  4. "Unable to install" on S60 v3 device
    By kraja in forum Symbian
    Replies: 1
    Last Post: 2006-07-10, 15:05

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×