×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    Mar 2012
    Posts
    2

    Problem playing .amr, .wav files in an alarm app on Nokia S40 device

    I have written an alarm app that plays a customized ringtone in the .amr format at a specified time. The app is written in Java ME and works on other supported devices but while the alarm comes up the file does not play. Please all help will be appreciated. Thanks.

  2. #2
    Nokia Developer Expert
    Join Date
    Aug 2007
    Posts
    1,595

    Re: Problem playing .amr, .wav files in an alarm app on Nokia S40 device

    Hello blackcoder007,

    and welcome to Nokia Developer Discussion Boards!

    Do you mean that the when the alarm gets launch the arm file will be played on other devices than on a Series 40 device?

    Regards,
    r2j7
    [URL="http://library.forum.nokia.com/java"][B] >>> Java Developer's Library <<<[/B][/URL]
    [URL="https://www.developer.nokia.com/Resources/Support/Technical_support.xhtml"] [B]>>> Technical Support for Java ME development <<<[/B][/URL]
    [URL="https://publish.ovi.com/info/"][B]>>> Nokia Publish: reach millions of Nokia users worldwide through Nokia Store <<<[/B][/URL]

  3. #3
    Registered User
    Join Date
    Mar 2012
    Posts
    2

    Re: Problem playing .amr, .wav files in an alarm app on Nokia S40 device

    Thanks r2j7,
    Yes that's exactly what's happening, I tried on a Nokia 1.1 SDK for Java emulator and got an error message that I have tried to debug to no avail. All help would be appreciated.
    http://i1050.photobucket.com/albums/...gger/error.png

  4. #4
    Registered User
    Join Date
    Nov 2011
    Location
    ahmedabad
    Posts
    32

    Re: Problem playing .amr, .wav files in an alarm app on Nokia S40 device

    Hi,

    I think you are using timer thread in the application. Now i am also developing the same kind of application in which i am fetching a wav file from the memory card and adding it in the player for infinite time. with loopcount -1. In this if i put thread.sleep then it is working in the emulator . But same jar is not working in the device.

    Hope to get the solution of this problem.

    Thanks
    Jigar

Similar Threads

  1. Problem with playing mp3 files
    By giaviv in forum Mobile Java Media (Graphics & Sounds)
    Replies: 3
    Last Post: 2010-03-16, 10:45
  2. Problem playing wav files
    By vladgets in forum Mobile Java Media (Graphics & Sounds)
    Replies: 1
    Last Post: 2009-07-10, 12:42
  3. problem while playing video files
    By akshay0912 in forum Mobile Java General
    Replies: 4
    Last Post: 2009-04-27, 06:56
  4. problem with playing *.mp4 files.
    By sis1987 in forum Mobile Java General
    Replies: 2
    Last Post: 2008-04-08, 09:23
  5. Problem in playing mpeg4 and 3gp files in nokia 6270
    By ganmax in forum Mobile Java Media (Graphics & Sounds)
    Replies: 3
    Last Post: 2006-04-08, 03:25

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×