×

Discussion Board

Results 1 to 15 of 16

Hybrid View

  1. #1
    Registered User
    Join Date
    Sep 2011
    Posts
    203

    Smart Installer "Installation Failed"

    Hi i am trying to use Smart installer to install Standard C++ Library Common(StdCpp) while installing Application.
    I downloaded Smart Installer from this link and added SmartInstaller at the end of pkg
    I am using S60 3rd edition FP1.
    Code:
    ; Embedded Smart Installer (required)
    @"$(EPOCROOT)Epoc32\InstallToDevice\SmartInstaller\smartinstaller_0_46_0_ss_nocs.sis",(0x2002CCCD)
    when Smart Installer start installing first Preparing Installation'll come then getting "Installation Failed"
    and then it'll ask for Select Connection after selecting nothing'll Install.

  2. #2
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,167

    Re: Smart Installer "Installation Failed"

    You could check the: http://www.developer.nokia.com/Commu...er_for_Symbian and Where to find help part and check what gets written to the logs.

    Also I suppose you are not having Qt app there, so how did you define the dependency in your applciation sis files pkg file, and how does your smart installer wrapper sis files pkg file look like ?

  3. #3
    Registered User
    Join Date
    Sep 2011
    Posts
    203

    Re: Smart Installer "Installation Failed"

    Quote Originally Posted by symbianyucca View Post
    Also I suppose you are not having Qt app there, so how did you define the dependency in your applciation sis files pkg file
    yes i dont have Qt app. I have not defined any dependency in my app sis pkg.
    .pkg
    Code:
    ;Language - standard language definitions
    &EN
    
    ; standard SIS file header
    #{"ZXingBarcodeReader"},(0x20060D8F),1,0,0
    
    ;Localised Vendor name
    %{"Forum Nokia"}
    
    ;Unique Vendor name
    :"Forum Nokia"
    
    ;Supports S60 3rd Edition
    [0x101F7961], 0, 0, 0, {"Series60ProductID"}
    
    ;Supports S60 5th Edition
    [0x1028315F], 0, 0, 0, {"S60ProductID"}
    
    ;Files to be installed	
    "..\data\App.jar"	- "d:\WidgetInstaller\App.jar"
    
    ;Installer files
    "..\data\WidgetInstFile"					  -"d:\WidgetInstaller\WidgetInstFile"
    
    "$(EPOCROOT)Epoc32\release\$(PLATFORM)\$(TARGET)\SoftwareInstaller_20060A5B.exe"		  -"!:\sys\bin\SoftwareInstaller_20060A5B.exe",FR,RI
    "$(EPOCROOT)Epoc32\release\$(PLATFORM)\$(TARGET)\Sample_2005F20E.exe"		  -"!:\sys\bin\Sample_2005F20E.exe",FR,RI
    
    ;Files to install
    "$(EPOCROOT)Epoc32\data\z\resource\apps\ZXingBarcodeReader_0x20060D8F.rsc"        -"!:\resource\apps\ZXingBarcodeReader_0x20060D8F.rsc"
    "$(EPOCROOT)Epoc32\data\z\private\10003a3f\apps\ZXingBarcodeReader_0x20060D8F_reg.rsc"    -"!:\private\10003a3f\import\apps\ZXingBarcodeReader_0x20060D8F_reg.rsc"
    "$(EPOCROOT)Epoc32\data\z\resource\apps\ZXingBarcodeReader_0x20060D8F.mif" -"!:\resource\apps\ZXingBarcodeReader_0x20060D8F.mif"
    "$(EPOCROOT)Epoc32\release\$(PLATFORM)\$(TARGET)\ZXingBarcodeReader_0x20060D8F.exe"       -"!:\sys\bin\ZXingBarcodeReader_0x20060D8F.exe",FR,RI
    ""                                                               -"C:\system\Sample\Sampletxt.txt", FILENULL
    
    ;CameraWrapper
    @"$(EPOCROOT)Epoc32\InstallToDevice\CameraWrapper\sis\camerawrapper.sisx", (0x2001ec5f)
    
    ; Embedded Smart Installer (required)
    @"$(EPOCROOT)Epoc32\InstallToDevice\SmartInstaller\smartinstaller_0_46_0_ss_nocs.sis",(0x2002CCCD)
    and how does your smart installer wrapper sis files pkg file look like ?
    I am using Smart installer which i got from this link
    http://www.developer.nokia.com/Commu...or_Symbian.zip
    smartinstaller_0_46_0_ss_nocs.sis

  4. #4
    Registered User
    Join Date
    Sep 2011
    Posts
    203

    Re: Smart Installer "Installation Failed"

    I missed these two lines and added it in pkg and tried to install
    ;PIPS library need to be installed.
    (0x20013851), 1, 7, 0, {"Symbian OS PIPS Library"}

    ;Standard C++ library need to be installed.
    (0x2000F866), 1, 7, 0, {"Symbian OS Standard C++ Library"}

    now instarting its asking for
    Component 'Symbian OS PIPS Library is missing' Continue anyway?
    and then
    Component 'Symbian OS Standard C++ Library is missing' Continue anyway?
    but it's not installing and again getting Installation Failed.
    is there any thing else i have to add?

  5. #5
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,167

    Re: Smart Installer "Installation Failed"

    Basically what you should do, is to have the dependencies included in the sis file holding your applciation, I assume that's right.

    So then you should remove the Smart installer from that sis file, and instead use the smart installer wrapper sis: http://doc.qt.nokia.com/smart-instal...er-format.html to actually handle the dependency installation with Smart installer.

    And Yes (for your next question), you need to sign your own application sis file first and then pack it with Smart installer Wrapper sis and sign this sis file separately.

  6. #6
    Registered User
    Join Date
    Sep 2011
    Posts
    203

    Re: Smart Installer "Installation Failed"

    Quote Originally Posted by symbianyucca View Post
    Basically what you should do, is to have the dependencies included in the sis file holding your applciation, I assume that's right.
    i have to add like this in my app pkg?
    Code:
    ;PIPS library need to be installed.
    (0x20013851), 1, 7, 0, {"Symbian OS PIPS Library"}
    
    ;Standard C++ library need to be installed.
    (0x2000F866), 1, 7, 0, {"Symbian OS Standard C++ Library"}
    
    ;OpenC and openCPP Lib Installer
    @"$(EPOCROOT)nokia_plugin\opencpp\s60opencppsis\STDCPP_s60_1_7_SS.sis",(0x2000F866)
    @"$(EPOCROOT)nokia_plugin\openc\s60opencsis\pips_s60_1_7_SS.sis", (0x20013851)
    So then you should remove the Smart installer from that sis file, and instead use the smart installer wrapper sis: http://doc.qt.nokia.com/smart-instal...er-format.html to actually handle the dependency installation with Smart installer.
    for Smart Installer wrapper i have to create new console app with this UID-0x2002CCCF
    and add these lines in pkg which is in this link, is this correct?

Similar Threads

  1. Molome Installation Failed with Smart Installer
    By whousah in forum [Archived] Nokia Smart Installer for Symbian
    Replies: 2
    Last Post: 2011-06-22, 22:13
  2. smart installer fails with "unable to delete file"
    By Nesma M. Rezk in forum [Archived] Nokia Smart Installer for Symbian
    Replies: 3
    Last Post: 2011-05-20, 14:09
  3. "Installation failed!" and then "Select Access Point" dialog pops up
    By stolik in forum [Archived] Nokia Smart Installer for Symbian
    Replies: 5
    Last Post: 2011-03-05, 00:31

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×