×

Discussion Board

Results 1 to 12 of 12

Thread: 'Help Please'

Hybrid View

  1. #1
    Registered User
    Join Date
    Mar 2012
    Posts
    6

    'Help Please'

    Hi.. I tried the code given below to send SMS using S40 Device Webapp,
    But i am getting error "NO Gateway Reply" in my device. is any setting required for this.?
    code is:
    "<a href="sms:+35801234567?body=hello%20world">SMS</a>"
    please reply me..if u r having any solution...

  2. #2
    Registered User
    Join Date
    Jun 2008
    Location
    Port Elizabeth, South Africa
    Posts
    37

    Re: 'Help Please'

    Hi,

    That looks like the correct format (as seen here: http://www.developer.nokia.com/Commu...es_40_web_apps)
    Are you sure that the Nokia Browser on your device is version 1.5 or better? Also, I'm pretty sure it will only work on a device and not in the simulator.

    I know the SMS URI scheme works as I have a web app in the store that uses it (Target Word)

    Regards,
    Stephen

  3. #3
    Nokia Developer Expert
    Join Date
    Jun 2008
    Location
    Tampere
    Posts
    833

    Re: 'Help Please'

    Hi pramod_pal,

    In what stage do you receive this "No gateway reply" error? (when loading the web app, clicking the link or sending SMS)

    -Ilkka

  4. #4
    Registered User
    Join Date
    Mar 2012
    Posts
    6

    Re: 'Help Please'

    Hi IlKKa
    when i am going to send the SMS..

  5. #5
    Nokia Developer Expert
    Join Date
    Jun 2008
    Location
    Tampere
    Posts
    833

    Re: 'Help Please'

    Hi,

    Thanks for clarification
    Can you send Text messages by just using phone's sms functionality, or do you reveive this error even then?

    Second thing to do is to uninstall 1.8 Beta version and get latest non-beta from: http://download.browser.ovi.com/

    Br,
    Ilkka

  6. #6
    Registered User
    Join Date
    Mar 2012
    Posts
    6

    Re: 'Help Please'

    Thanks Ilkka '
    using phone sms functionality it is working well.
    is it sure that sms functionality works only with non-beta version browser only....

  7. #7
    Registered User
    Join Date
    Mar 2012
    Posts
    6

    Re: 'Help Please'

    Hi Ilkka,
    using this URL i got browser version 2.0.1.62.6
    then i used this browser but i am getting same error
    No gateway reply
    durind sending sms using S40 web app. please tell me how to download browser version 1.5 or how to solve this problem...?

  8. #8
    Registered User
    Join Date
    Mar 2012
    Posts
    6

    Re: 'Help Please'

    thanks stephen,
    but i updated my browser with latest one (1.8) using nokia suit, but i typed URL on this browser and getting error :
    Unable to complete operation (006)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×