×

Discussion Board

Results 1 to 12 of 12

Thread: 'Help Please'

  1. #1
    Registered User
    Join Date
    Mar 2012
    Posts
    6

    'Help Please'

    Hi.. I tried the code given below to send SMS using S40 Device Webapp,
    But i am getting error "NO Gateway Reply" in my device. is any setting required for this.?
    code is:
    "<a href="sms:+35801234567?body=hello%20world">SMS</a>"
    please reply me..if u r having any solution...

  2. #2
    Registered User
    Join Date
    Jun 2008
    Location
    Port Elizabeth, South Africa
    Posts
    37

    Re: 'Help Please'

    Hi,

    That looks like the correct format (as seen here: http://www.developer.nokia.com/Commu...es_40_web_apps)
    Are you sure that the Nokia Browser on your device is version 1.5 or better? Also, I'm pretty sure it will only work on a device and not in the simulator.

    I know the SMS URI scheme works as I have a web app in the store that uses it (Target Word)

    Regards,
    Stephen

  3. #3
    Super Contributor
    Join Date
    Jun 2008
    Location
    Tampere
    Posts
    833

    Re: 'Help Please'

    Hi pramod_pal,

    In what stage do you receive this "No gateway reply" error? (when loading the web app, clicking the link or sending SMS)

    -Ilkka

  4. #4
    Registered User
    Join Date
    Mar 2012
    Posts
    6

    Re: 'Help Please'

    thanks stephen,
    but i updated my browser with latest one (1.8) using nokia suit, but i typed URL on this browser and getting error :
    Unable to complete operation (006)

  5. #5
    Registered User
    Join Date
    Mar 2012
    Posts
    6

    Re: 'Help Please'

    Hi IlKKa
    when i am going to send the SMS..

  6. #6
    Super Contributor
    Join Date
    Jun 2008
    Location
    Tampere
    Posts
    833

    Re: 'Help Please'

    Hi,

    Thanks for clarification
    Can you send Text messages by just using phone's sms functionality, or do you reveive this error even then?

    Second thing to do is to uninstall 1.8 Beta version and get latest non-beta from: http://download.browser.ovi.com/

    Br,
    Ilkka

  7. #7
    Registered User
    Join Date
    Mar 2012
    Posts
    6

    Re: 'Help Please'

    Thanks Ilkka '
    using phone sms functionality it is working well.
    is it sure that sms functionality works only with non-beta version browser only....

  8. #8
    Registered User
    Join Date
    Mar 2012
    Posts
    6

    Re: 'Help Please'

    Hi Ilkka,
    using this URL i got browser version 2.0.1.62.6
    then i used this browser but i am getting same error
    No gateway reply
    durind sending sms using S40 web app. please tell me how to download browser version 1.5 or how to solve this problem...?

  9. #9
    Super Contributor
    Join Date
    Jun 2008
    Location
    Tampere
    Posts
    833

    Re: 'Help Please'

    Hi,

    The browser version you got from download.browser.ovi.com is a good one. I have been using it send SMS without any problems.
    I would need to know phone model and firmware version (enter *#0000# into dialer). Sorry about these endless questions, but I'll try to reproduce the issue in this end.

    By the way, have you checked, if message body and receiver phone number is filled in to SMS editor after clicking the link?

    Br,
    Ilkka

  10. #10
    Registered User
    Join Date
    Mar 2012
    Posts
    6

    Re: 'Help Please'

    thanks Ilkka,
    The phone models on which I have tested are Nokia X3-02 and Nokia X2-00.

  11. #11
    Super Contributor
    Join Date
    Jun 2008
    Location
    Tampere
    Posts
    833

    Re: 'Help Please'

    Hi,

    Sorry for late reply.
    I tried with latest browser and with X3-02 and for me it works nicely.
    I'll forward this report to RnD, and therefore needing some additional details.

    Could you recap the steps needs to be taken to make this error happen.
    Something like below:
    1) start web app
    2) click SMS uri link (<a href="sms:fill-in-here">send SMS</a> )
    3) sms editor is opened (is it?)
    4) are body message and phone number OK?
    5) ...

    In addition firmware version of X3-02 and possibly operator would be nice to know.

    Br,
    Ilkka

  12. #12
    Registered User
    Join Date
    Sep 2012
    Posts
    1

    Re: 'Help Please'

    How did this resolve please.
    I'm having the same problem with an X2-01

    When i click the link on the web app to send the SMS, I get No Gateway Reply

    incidentally, when I use "tel" instead of SMS it prompts if I want to make a call to ...

    V 08.65
    RM-709

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •