×

Discussion Board

Page 1 of 2 12 LastLast
Results 1 to 15 of 19
  1. #1
    Registered User
    Join Date
    Mar 2012
    Posts
    7

    Phone does not reconnect to cellular network when connection lost

    Any progress on the problem with the phone not reconnecting to cellular network when connection lost?

    One of the more fundamental features of a phone must be to have some kind of connection with the world around it, and if it loses that connection at least provide a notification that so has happened.
    Not as the Nokia N9, which happily indicates full signal strength and a blue dot for 3G connection while under the hood it seems to have lost the net completely. The only notification I get is when friends or colleagues tells me that people have tried to reach me but my phone seems to be turned off.

    Think it is sad as I grown quite fond of the phone. But I'm ready to give up. I have tested a couple of different N9 phones, different network operators and awaited a couple of firmware updates without any improvements.

    Spoke with the people at Nokia Care but they didn't think the problem would ever get a solution and recommended me to bring the phone back to the store for a money refund.


    //j

  2. #2
    Super Contributor
    Join Date
    Mar 2009
    Posts
    1,024

    Re: Phone does not reconnect to cellular network when connection lost

    Hi,
    I've been using N9 for long time now and to be honest I never faced this problem, or at least I didn't noticed that.
    What happens when you call when the phone has lost the connection?
    Does this happen randomly or just in some areas?

  3. #3
    Registered User
    Join Date
    Mar 2012
    Posts
    7

    Re: Phone does not reconnect to cellular network when connection lost

    Hard to tell exactly what happens as there is no direct indication when connection is lost (sometimes you notice that the phone has failed to sync emails or similar and that is a good indicator that it has been of the net for a while).
    When it happens I am often able to make outgoing calls and I think when doing so incoming starts working also. Other times all communication are blocked and the only way to solve it is to restart the phone.

    The problem seems to be related to when phone switches between GSM <-> 3G as locking the phone to GSM mode only makes it work better. Also noticed similar behaviour when travelling and phone frequently has to switch between different cell towers.

    I guess it, in some way, must be related to the network topology in the areas where I reside as I have friends using the same type of phone without problems while other describes the exact same behaviour. But even if it is something related to the network the Nokia N9 handles it worse than others. I have a number of different phones, Nokias and other brands, and I detects none of these problems when switching to one of them.

    //j

  4. #4
    Super Contributor
    Join Date
    Mar 2009
    Posts
    1,024

    Re: Phone does not reconnect to cellular network when connection lost

    Harmattan is a young system compared to others (Symbian, s40, android...).
    It could be there is something wrong in the way it handles these situations.

    Nokia devices, before to go to market, have to pass very severe tests.
    It could be that R&D knows about this issue but they think this is something minor which they are not going to fix right now.

    If you have problems with calls too, then it's a modem problem for sure.
    If it's just about internet it could be something wrong with harmattan middlewere.

    For sure in both cases you don't have to switch off the phone to get it working again.
    In the worst case setting flight mode should be enough.

  5. #5
    Registered User
    Join Date
    Mar 2012
    Posts
    7

    Re: Phone does not reconnect to cellular network when connection lost

    The R&D knows about the problem, has been tagged as a high priority case since mid November last year.

    The problem occurs with both voice and data, both incoming and outgoing, like RX/TX circuits are totally shut of but phone still indicates full signal strength and active 3G connection. Have, when problem present, been in contact with the network operator just to verify there are no problem at their end.

    Putting the phone in flight mode and back (or cycling through GSM -> 3G -> Dual) sometimes solves the it but often a reboot is the only way to get it to reconnect. After toggling flightmode the phone shows an empty signal strength meter with a red dash and no operator logo. At one occasion I waited for around 10minutes before I gave up and rebooted just to see if it would go online after a while.

    //j

  6. #6
    Super Contributor
    Join Date
    Mar 2009
    Posts
    1,024

    Re: Phone does not reconnect to cellular network when connection lost

    Could you please tell me the bug reference number or URL?
    I will check why it has not been fixed yet even if it has high priority status.

  7. #7
    Registered User
    Join Date
    Mar 2012
    Posts
    7

    Re: Phone does not reconnect to cellular network when connection lost


  8. #8
    Super Contributor
    Join Date
    Mar 2009
    Posts
    1,024

    Re: Phone does not reconnect to cellular network when connection lost

    Thanks for sharing.
    I've just mailed couple of people just to understand what's going on with the bug.
    I will try to push it forward as much as I can, but I cannot really give you any warranty.
    I will keep you posted

  9. #9
    Super Contributor
    Join Date
    Mar 2009
    Posts
    1,024

    Re: Phone does not reconnect to cellular network when connection lost

    Hi,
    Just received an answer. In my understanding there are very few chance to see thjis bug fixed.

    It was marked as fixed since the fix was integrated in PR 1.2.
    But Soumya has reopened the bug due to your (community) comments.

    The main problem with this bug is the reproducibility. It sounds to me that they thought they fixed the bug because they have not been able to reproduce it.

  10. #10
    Registered User
    Join Date
    Mar 2012
    Posts
    7

    Re: Phone does not reconnect to cellular network when connection lost

    OK,

    A good practice is to not tag bugs as "resolved" and "fixed" when closed due to un-reproducibility. All bug/issue tracking system I know of has the option "not_reproducible" which informs the users of the problem and allows them to provide more information.

    //j

  11. #11
    Super Contributor
    Join Date
    Mar 2009
    Posts
    1,024

    Re: Phone does not reconnect to cellular network when connection lost

    I agree with you, but I don't know the actual story behind the "fixed" tag.
    For sure If they marked it as "fixed" they have found and fixed something that in their understading was the bug.

  12. #12
    Registered User
    Join Date
    Apr 2012
    Posts
    1

    Re: Phone does not reconnect to cellular network when connection lost

    Hi,

    I'm also experiencing this problem quite often. I am up-to-date, though.

  13. #13
    Registered User
    Join Date
    Apr 2012
    Posts
    1

    Re: Phone does not reconnect to cellular network when connection lost

    I´m experiencing the same problem with Lumia 710, WP7. The phone seems to be okay and it shows that I have 3g connection but when I try to make a call it doesn´t work and I have to login on to my SIM. This is very annoiying since I loose business when people can´t reach me. Any suggestions on the problem?

  14. #14
    Nokia Developer Champion
    Join Date
    Feb 2008
    Location
    Ahmedabad, Gujarat, India
    Posts
    3,852

    Re: Phone does not reconnect to cellular network when connection lost

    Quote Originally Posted by RainerK1 View Post
    I´m experiencing the same problem with Lumia 710, WP7. The phone seems to be okay and it shows that I have 3g connection but when I try to make a call it doesn´t work and I have to login on to my SIM. This is very annoiying since I loose business when people can´t reach me. Any suggestions on the problem?
    and how your information is related to this forum ??

  15. #15
    Nokia Developer Moderator
    Join Date
    Oct 2006
    Location
    Finland
    Posts
    4,559

    Re: Phone does not reconnect to cellular network when connection lost

    Quote Originally Posted by RainerK1 View Post
    I´m experiencing the same problem with Lumia 710, WP7. The phone seems to be okay and it shows that I have 3g connection but when I try to make a call it doesn´t work and I have to login on to my SIM. This is very annoiying since I loose business when people can´t reach me. Any suggestions on the problem?
    Your query is neither related to the device family in question, nor to the forum. This discussion board caters to problems faced by 3rd party application developers. For end users forum and peer support please post your query in http://discussions.europe.nokia.com/...rt_Discussions

Similar Threads

  1. N8 failed to reconnect, once WLAN connection lost.
    By jawadakhtar in forum Symbian Networking & Messaging (Closed)
    Replies: 3
    Last Post: 2010-12-29, 07:32
  2. Smart Installer hangs if network connection lost
    By danhicksbyron in forum [Archived] Nokia Smart Installer for Symbian
    Replies: 0
    Last Post: 2010-07-21, 21:39
  3. HTTP Connection behaviour when 3G connection is lost (or being lost)
    By TwmD in forum Mobile Java Networking & Messaging & Security
    Replies: 6
    Last Post: 2010-01-27, 12:36
  4. use of a fixed cellular network
    By jackdaniels84 in forum Symbian Networking & Messaging (Closed)
    Replies: 1
    Last Post: 2008-01-14, 13:47
  5. Replies: 0
    Last Post: 2003-03-10, 03:46

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×