×

Discussion Board

Results 1 to 7 of 7
  1. #1
    Registered User
    Join Date
    Oct 2010
    Posts
    19

    Question problems with menu on Symbian 5th Ed

    Hi everybody.
    I have next problem with menu on my Nokia 5800: sometimes when I bring my application to foreground and then press cba Options (where menu is existed with 4 items), only highlighted item is visible. Other menu items are invisible, but menu pane has the same size. Texts of other menu items are invisible and I can't select them.
    When I press cba Cancel and then again Options, all menu items in the pane are visible and can be selected.
    I dont have this problem on devices with OS 3rd Ed, Belle. It occurs only on 5th Ed.
    Does anybody know the reason of this strange bug?

  2. #2
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,167

    Re: problems with menu on Symbian 5th Ed

    newer seen this kind of bug, anyway, do check what base class your appui class is derived, and make sure it is only based the view app ui, if you are only using views, and if you use CCoeControls directly, then make sure it is not derived from view app ui base class.

    Also you could see whether you can repeat the problem with Hewlloworld type application, and if you can, then make a bug report for it.

  3. #3
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,674

    Re: problems with menu on Symbian 5th Ed

    Is skinning enabled? The EAknEnableSkin thing passed in AppUi::ConstructL to BaseConstructL

  4. #4
    Registered User
    Join Date
    Oct 2010
    Posts
    19

    Re: problems with menu on Symbian 5th Ed

    Yes, skinning is enabled.
    Also, usually this bug is reproduced, when I bring application to foreground (from background). On application lauch it doesn't happen.

  5. #5
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,674

    Re: problems with menu on Symbian 5th Ed

    Can it be a firmware issue perhaps? If you have time you may consider checking either if there is an update, or with the 5800-s in RDA (Devices above, Remote Device Access). Apparently there are two versions available, 50.something and 60.something.

  6. #6
    Registered User
    Join Date
    Oct 2010
    Posts
    19

    Re: problems with menu on Symbian 5th Ed

    On device with firmware v.10 this issue occurs, but on device with firmware v.40 - no. Can it depend on device firmware? or is it my fault?

  7. #7
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,674

    Re: problems with menu on Symbian 5th Ed

    It is likely a firmware issue then. Bug report is not necessary if you find the issue has been fixed with new versions.

Similar Threads

  1. problems with appiufw.app.menu
    By Mariannu in forum Symbian
    Replies: 2
    Last Post: 2009-09-14, 00:11
  2. problems with menu
    By velho.oto in forum Mobile Java General
    Replies: 2
    Last Post: 2008-12-03, 05:08
  3. Problems with menu
    By velho.oto in forum Mobile Java General
    Replies: 1
    Last Post: 2008-08-17, 06:00
  4. Menu problems
    By SevenOfEleven in forum Mobile Java General
    Replies: 2
    Last Post: 2005-12-13, 00:39

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×