×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Regular Contributor
    Join Date
    Jul 2007
    Posts
    151

    Why smartinstaller downloaded the qtcomponents's version is wrong

    In my .pro file
    my_deployment.pkg_prerules += \
    "(0x200346DE), 1, 0, 0, {\"Qt Quick components\"}"
    DEPLOYMENT += my_deployment
    CONFIG += qt-components

    The creator generate the pkg files, there in the pkg file the
    (0x200346DE), 1, 0, 0, {"Qt Quick components"}

    But , when i install the application, is download the qt-components, but it's version is 1.01. That cause my application runing incorrect.
    If i package the qt-components.sis(1.00) in the .sis, the user the smartinstaller down it
    My application runing correct.

    Is the smartinstaller will down the latest qt-components?
    Keep Smiling To Life!

    Dynasty1215

  2. #2
    Regular Contributor
    Join Date
    Jul 2007
    Posts
    151

    Re: Why smartinstaller downloaded the qtcomponents's version is wrong

    I founded this:http://www.developer.nokia.com/Commu...er_for_Symbian

    Note:Qt Quick Components 1.0 package is not anymore available in Smart Installer. Smart Installer will only provide Qt Quick Components 1.1 package. 1.1 package includes both Qt Quick Components versions 1.0 and 1.1.

    Nokia's behavior is puzzled.
    Keep Smiling To Life!

    Dynasty1215

  3. #3
    Super Contributor
    Join Date
    Jun 2006
    Location
    India
    Posts
    3,037

    Re: Why smartinstaller downloaded the qtcomponents's version is wrong

    As I knw, now everyone is using version 1.1 and it is always good to used higher version. Which have lots of new things and fixes for previous issues.
    Use [URL="http://qt.nokia.com/products/qt-quick/"]Qt-Quick[/URL] to make your application UI more attractive.

    [URL="http://store.ovi.com/content/271896"]http://store.ovi.com/content/271896[/URL] | [URL="http://store.ovi.com/content/276199"]http://store.ovi.com/content/276199[/URL] |[URL="http://store.ovi.com/content/276202"] http://store.ovi.com/content/276202[/URL] | [URL="http://store.ovi.com/content/280827"]http://store.ovi.com/content/280827[/URL]

  4. #4
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,166

    Re: Why smartinstaller downloaded the qtcomponents's version is wrong

    Yep, when newer version is supported it should always be downloaded, thus you must test your application with newest supported dependencies for the devices you are planing to distribute your application to.

Similar Threads

  1. Inapp application - getting the issue "class file has wrong version..
    By Ranjanm in forum Mobile Java Tools & SDKs
    Replies: 1
    Last Post: 2011-09-14, 10:00
  2. What is the right way to add FILETEXT in SmartInstaller package?
    By oskarinarki in forum [Archived] Nokia Smart Installer for Symbian
    Replies: 3
    Last Post: 2011-03-29, 06:53
  3. EclipseME - Wrong MIDP Version - S40 6th SDK
    By Microman171 in forum Mobile Java Tools & SDKs
    Replies: 6
    Last Post: 2010-11-09, 22:22
  4. wrong version published from ovi
    By florianhaar in forum [Closed] Publishing to Nokia Store
    Replies: 4
    Last Post: 2010-03-15, 07:37
  5. Wrong Java Version ?
    By humpf in forum WAP Servers
    Replies: 1
    Last Post: 2002-09-29, 06:50

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×