×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    Oct 2011
    Posts
    6

    Cannot Update "Nokia Series 40 Web Tools Component"

    After uninstalling (!) 1.2 and installing 1.5 afterwards (Windows), I saw there's updates to "Nokia Series 40 Web Tools Component" and "Series 40 Web App Samples". The update fails and gives me the following error message:


    Cannot complete the install because of a conflicting dependency.
    Software being installed: Series 40 Web App Samples 1.5.0.201201061127 (com.nokia.wrt.addon.s40.samples.feature.feature.group 1.5.0.201201061127)
    Software currently installed: Shared profile 1.0.0.1318434075925 (SharedProfile_WDEProfile 1.0.0.1318434075925)
    Only one of the following can be installed at once:
    Nokia Series 40 web app samples 1.2.0.201110122136 (com.nokia.wrt.addon.s40.samples 1.2.0.201110122136)
    Nokia Series 40 web app samples 1.5.0.201201061127 (com.nokia.wrt.addon.s40.samples 1.5.0.201201061127)
    Cannot satisfy dependency:
    From: Shared profile 1.0.0.1318434075925 (SharedProfile_WDEProfile 1.0.0.1318434075925)
    To: com.nokia.wrt.addon.s40.samples [1.2.0.201110122136]
    Cannot satisfy dependency:
    From: Series 40 Web App Samples 1.5.0.201201061127 (com.nokia.wrt.addon.s40.samples.feature.feature.group 1.5.0.201201061127)
    To: com.nokia.wrt.addon.s40.samples [1.5.0.201201061127]
    and



    Cannot complete the install because of a conflicting dependency.
    Software being installed: Nokia Series 40 Web Tools Component 1.5.0.201112221608 (com.nokia.wrt.addon.s40.feature.feature.group 1.5.0.201112221608)
    Software currently installed: Shared profile 1.0.0.1318434075925 (SharedProfile_WDEProfile 1.0.0.1318434075925)
    Only one of the following can be installed at once:
    Nokia Series 40 Web Tools Component 1.2.0.201110122136 (com.nokia.wrt.addon.s40.feature.feature.jar 1.2.0.201110122136)
    Nokia Series 40 Web Tools Component 1.5.0.201112221608 (com.nokia.wrt.addon.s40.feature.feature.jar 1.5.0.201112221608)
    Cannot satisfy dependency:
    From: Shared profile 1.0.0.1318434075925 (SharedProfile_WDEProfile 1.0.0.1318434075925)
    To: com.nokia.wrt.addon.s40.feature.feature.jar [1.2.0.201110122136]
    Cannot satisfy dependency:
    From: Nokia Series 40 Web Tools Component 1.5.0.201112221608 (com.nokia.wrt.addon.s40.feature.feature.group 1.5.0.201112221608)
    To: com.nokia.wrt.addon.s40.feature.feature.jar [1.5.0.201112221608]
    Any ideas?

  2. #2
    Super Contributor
    Join Date
    Jun 2008
    Location
    Tampere
    Posts
    833

    Re: Cannot Update "Nokia Series 40 Web Tools Component"

    Hi,

    Did you use same installation directory for both versions? I have noticed, that uninstalling may not delete all files in installation directory.
    Please try to uninstall once more and make sure that target directory is empty.

    Br,
    Ilkka

  3. #3
    Nokia Developer Champion
    Join Date
    Nov 2011
    Posts
    79

    Re: Cannot Update "Nokia Series 40 Web Tools Component"

    Hi All,

    This issue is related to user level privileges on Windows. I had the same problem on one of the development PCs and at the same time, other PC didn't exhibit any problems. Then I realized that one was using default Administrator user and other didn't. So, during installation and execution make sure you will use administrative level privileges. If you are not booted into Administrator user, right-click on installation executable file "NokiaWebTools_1.5.0.exe" and select "Run as administrator". During development instructions are exactly the same: Use right click / "Run as administrator" on "Nokia Web Developer Environment" from Windows Start or Programs menu.

    You can change default properties of the launching link permanently, so it will always use administrator privileges.

    Of course simplest way is to use Administrator account always for development.

    Best,
    Michael

  4. #4
    Super Contributor
    Join Date
    Jun 2008
    Location
    Tampere
    Posts
    833

    Re: Cannot Update "Nokia Series 40 Web Tools Component"

    Thanks Michael!
    -Ilkka

Similar Threads

  1. [Moved] "Unable to install. Component is built in." on N86 8mp nokia phone
    By chandran.biju007 in forum Symbian Signed Support, Application Packaging and Distribution and Security
    Replies: 3
    Last Post: 2010-03-22, 16:45
  2. Replies: 4
    Last Post: 2008-05-20, 19:07
  3. Replies: 1
    Last Post: 1970-01-01, 02:00

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •