Hi,

I am having a compile problem. First off, it was compiling fine before, and it sill compiles fine in CodeWarrior, just not via command line anymore.

All I did was add a "SOURCE file.cpp" line into the .mmp file

Then I "abld clean" and "bldmake clean"

Then I did a "bldmake bldfiles" and a "abld build thumb urel"

But its complaining about missing make files. I'm assuming these files should of got created by bldmake.

Below is the output:

Code:
C:\code\series60\MINOtaur\group>bldmake -v bldfiles
Reading "\CODE\SERIES60\MINOTAUR\GROUP\BLD.INF" for platforms and exports
Platforms: "WINS THUMB ARMI VC6"
Reading "\CODE\SERIES60\MINOTAUR\GROUP\BLD.INF" for WINS
Reading "\CODE\SERIES60\MINOTAUR\GROUP\BLD.INF" for THUMB
Reading "\CODE\SERIES60\MINOTAUR\GROUP\BLD.INF" for ARMI
Creating "\Symbian\Series60_CW\EPOC32\BUILD\CODE\SERIES60\MINOTAUR\GROUP\PLATFORM.PM"
Creating "\CODE\SERIES60\MINOTAUR\GROUP\ABLD.BAT"
Creating "\Symbian\Series60_CW\EPOC32\BUILD\CODE\SERIES60\MINOTAUR\GROUP\EXPORT.MAKE"
Creating "\Symbian\Series60_CW\EPOC32\BUILD\CODE\SERIES60\MINOTAUR\GROUP\EXPORTTEST.MAKE"
Creating "\Symbian\Series60_CW\EPOC32\BUILD\CODE\SERIES60\MINOTAUR\GROUP\WINS.MAKE"
Creating "\Symbian\Series60_CW\EPOC32\BUILD\CODE\SERIES60\MINOTAUR\GROUP\THUMB.MAKE"
Creating "\Symbian\Series60_CW\EPOC32\BUILD\CODE\SERIES60\MINOTAUR\GROUP\ARMI.MAKE"
Creating "\Symbian\Series60_CW\EPOC32\BUILD\CODE\SERIES60\MINOTAUR\GROUP\VC6.MAKE"
Creating "\Symbian\Series60_CW\EPOC32\BUILD\CODE\SERIES60\MINOTAUR\GROUP\WINSTEST.MAKE"
Creating "\Symbian\Series60_CW\EPOC32\BUILD\CODE\SERIES60\MINOTAUR\GROUP\THUMBTEST.MAKE"
Creating "\Symbian\Series60_CW\EPOC32\BUILD\CODE\SERIES60\MINOTAUR\GROUP\ARMITEST.MAKE"
Creating "\Symbian\Series60_CW\EPOC32\BUILD\CODE\SERIES60\MINOTAUR\GROUP\VC6TEST.MAKE"
Creating test batch files in "\Symbian\Series60_CW\EPOC32\BUILD\CODE\SERIES60\MINOTAUR\GROUP\" for WINS
Creating test batch files in "\Symbian\Series60_CW\EPOC32\BUILD\CODE\SERIES60\MINOTAUR\GROUP\" for THUMB
Creating test batch files in "\Symbian\Series60_CW\EPOC32\BUILD\CODE\SERIES60\MINOTAUR\GROUP\" for ARMI
That seems fine to me, but the problem is when I try run "abld build thumb urel"
Code:
C:\code\series60\MINOtaur\group>abld -v build thumb urel
  make -r  -f "\Symbian\Series60_CW\EPOC32\BUILD\CODE\SERIES60\MINOTAUR\GROUP\EXPORT.make" EXPORT
make: `EXPORT' is up to date.
  make -r  -f "\Symbian\Series60_CW\EPOC32\BUILD\CODE\SERIES60\MINOTAUR\GROUP\THUMB.make" MAKEFILE
make: Nothing to be done for `MAKEFILE'.
  make -r  -f "\Symbian\Series60_CW\EPOC32\BUILD\CODE\SERIES60\MINOTAUR\GROUP\THUMB.make" LIBRARY
make   -r -f "\Symbian\Series60_CW\EPOC32\BUILD\CODE\SERIES60\MINOTAUR\GROUP\MINOTAUR\THUMB\MINOTAUR.THUMB" LIBRARY
make[1]: \Symbian\Series60_CW\EPOC32\BUILD\CODE\SERIES60\MINOTAUR\GROUP\MINOTAUR\THUMB\MINOTAUR.THUMB: No such file or directory
make[1]: *** No rule to make target `\Symbian\Series60_CW\EPOC32\BUILD\CODE\SERIES60\MINOTAUR\GROUP\MINOTAUR\THUMB\MINOTAUR.THUMB'.  Stop.
make[1]: Entering directory `C:/CODE/SERIES60/MINOTAUR/GROUP'
make[1]: Leaving directory `C:/CODE/SERIES60/MINOTAUR/GROUP'
make: *** [LIBRARYMINOTAUR] Error 2
  make -r  -f "\Symbian\Series60_CW\EPOC32\BUILD\CODE\SERIES60\MINOTAUR\GROUP\THUMB.make" RESOURCE CFG=UREL
make   -r -f "\Symbian\Series60_CW\EPOC32\BUILD\CODE\SERIES60\MINOTAUR\GROUP\MINOTAUR\THUMB\MINOTAUR.THUMB" RESOURCEUREL
make[1]: \Symbian\Series60_CW\EPOC32\BUILD\CODE\SERIES60\MINOTAUR\GROUP\MINOTAUR\THUMB\MINOTAUR.THUMB: No such file or directory
make[1]: *** No rule to make target `\Symbian\Series60_CW\EPOC32\BUILD\CODE\SERIES60\MINOTAUR\GROUP\MINOTAUR\THUMB\MINOTAUR.THUMB'.  Stop.
make[1]: Entering directory `C:/CODE/SERIES60/MINOTAUR/GROUP'
make[1]: Leaving directory `C:/CODE/SERIES60/MINOTAUR/GROUP'
make: *** [RESOURCEMINOTAUR] Error 2
  make -r  -f "\Symbian\Series60_CW\EPOC32\BUILD\CODE\SERIES60\MINOTAUR\GROUP\THUMB.make" TARGET CFG=UREL
make   -r -f "\Symbian\Series60_CW\EPOC32\BUILD\CODE\SERIES60\MINOTAUR\GROUP\MINOTAUR\THUMB\MINOTAUR.THUMB" UREL
make[1]: \Symbian\Series60_CW\EPOC32\BUILD\CODE\SERIES60\MINOTAUR\GROUP\MINOTAUR\THUMB\MINOTAUR.THUMB: No such file or directory
make[1]: *** No rule to make target `\Symbian\Series60_CW\EPOC32\BUILD\CODE\SERIES60\MINOTAUR\GROUP\MINOTAUR\THUMB\MINOTAUR.THUMB'.  Stop.
make[1]: Entering directory `C:/CODE/SERIES60/MINOTAUR/GROUP'
make: *** [TARGETMINOTAUR] Error 2
make[1]: Leaving directory `C:/CODE/SERIES60/MINOTAUR/GROUP'
  make -r  -f "\Symbian\Series60_CW\EPOC32\BUILD\CODE\SERIES60\MINOTAUR\GROUP\THUMB.make" FINAL CFG=UREL
make: Nothing to be done for `FINAL'.
Now to me it seems it cant find the "\Symbian\Series60_CW\EPOC32\BUILD\CODE\SERIES60\MINOTAUR\GROUP\MINOTAUR\THUMB\MINOTAUR.THUMB" file
Infact, i have the directory "\Symbian\Series60_CW\EPOC32\BUILD\CODE\SERIES60\MINOTAUR\GROUP\" but that directory has no subdirs

Can someone help point me in the right direction of whats failing.

Thanks