×

Discussion Board

Results 1 to 1 of 1
  1. #1
    Registered User
    Join Date
    Jan 2009
    Posts
    25

    CSenServiceConnection SetStatus with status -1

    I am using CSenServiceConnection to send the xml request. But my SetStatus in some devices always called with status -1 which is KSenConnectionStatusCreateFailed. here is fragment of my code:

    servicePattern = CSenServicePattern::NewLC(KSoapServer, KNullDesC8);
    servicePattern->SetFrameworkIdL(KDefaultBasicWebServicesFrameworkID);
    servicePattern->SetContractL(KPpContract);
    iConnection= CSenServiceConnection::NewL(*this,*servicePattern);

    In some devices, it works fine. But in other devices, the SetStatus is been called with status as -1.
    I also tried to add the following before the creation of iConnection:

    servicePattern->SetConsumerIapIdL(1)

    But it is the same result.

    Please help me out!
    TIA
    Last edited by serickson@fb-4.com; 2012-04-12 at 16:09.

Similar Threads

  1. Problem in using CSenServiceConnection API for Web Services
    By Sachin Tikare in forum Symbian Networking & Messaging (Closed)
    Replies: 0
    Last Post: 2009-09-08, 10:49
  2. CSenServiceConnection and HTTP headers
    By kelju in forum Symbian Networking & Messaging (Closed)
    Replies: 0
    Last Post: 2009-03-14, 13:24
  3. WebService and SetStatus()
    By SimonJudge in forum Symbian Networking & Messaging (Closed)
    Replies: 1
    Last Post: 2007-08-14, 13:34
  4. SetStatus() method of MUINotifier panics in sockets engine with KERN-EXEC 3
    By razas in forum Symbian Networking & Messaging (Closed)
    Replies: 0
    Last Post: 2006-02-13, 05:34

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×