Hi all. I wish to learn QT and develop some simple apps for my moms' Nokia N95 8GB and my sisters' Nokia 5230. After a lot of reading I've concluded that the QT SDK version I need is 1.1.2.

However, the download page says it's a 1.78GB download and I'm on a pay-per-use internet connection so I'd like someone to confirm whether it's the right SDK for me to download. If I'm wrong that'll be ~20 bucks down the drain.

Will I also be able to target Belle using QT SDK 1.1.2 using the same code base?