×

Discussion Board

Results 1 to 6 of 6
  1. #1
    Registered User
    Join Date
    May 2011
    Posts
    35

    CODA no longer working with 701 since system update

    Hi there,

    Anyone else experiencing this? I had an over the air update a couple of days ago on my Nokia 701 that I accepted and since then I can't get CODA to work at all, which, as you can imagine, has pretty much blocked any continued development.

    When trying to run the application from Qt Creator I get the following sequence:
    1) Application installs to the phone
    2) Qt Creator's console output logs a disconnection from CODA on the device and Windows registers the entire device as disconnecting from the USB connection
    3) Phone launches a black screen with the 5 scanning dots
    4) This runs for around 5-10 seconds and then disappears
    6) After this I can launch the application manually
    [At some point during (3) and (4) CODA exits on the phone]

    When trying to debug an application from Qt Creator I get the following:
    1) Dialog pop-up with the same disconnection error message and the title "Adapter crashed"

    Last night I went through the "Update QT SDK" application and selected everything , my QT Creator about text is:

    "Qt Creator 2.4.1
    Based on Qt 4.7.4 (32 bit)

    Built on Jan 26 2012 at 09:48:31

    From revision 8cd370e163"

    I really, really can't afford any delays like this on this project and would greatly appreciate any help on the matter and to hear if anyone else's 701s are working or not.

  2. #2
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,355

    Re: CODA no longer working with 701 since system update

    The CODA installer contains two binaries, one designed for use with Anna/Belle and one containing the changes required for Belle FP1. If you have installed CODA on Anna/Belle the first variant of the binary was installed, but that is no longer working after Belle FP1 is flashed. So the solution should be simple, re-install CODA on the device, so that the FP1-compatible version replaces the Anna/Belle one.
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  3. #3
    Registered User
    Join Date
    May 2011
    Posts
    35

    Re: CODA no longer working with 701 since system update

    Thanks for the reply. I've got two CODA sis files in my Qt installation, both under the following path:
    QtSDK\Symbian\sis\common\CODA

    1)Public-CODA-1.0.5-b2-for-S60v5-Anna-Belle
    This is what the SDK points to under it's installation when I go Start -> Qt SDK -> Symbian Belle Qt 4.7.4
    This is the installer that's resulting in the errors I'm seeing and this is based on a fresh install after taking off the old one.
    I don't have a Symbian SDK downloaded so can't run DumpSIS on it to drill down into the contents, but perhaps the filename is enough to identify if it's the up to date installer?

    2) Public-CODA-1.0.6-for-S60v5-Anna-Belle-vFuture
    I'm assuming despite the 1.0.6 part that this is a legacy installer given the rest of the filename but I gave it a try anyway. Tried both breakpoint modes and got KErrPermissionDenied errors claiming I needed to add some macros to the MMP file. So I'm assuming this isn't the correct installer, is that correct?

    Thanks for your help (it seems some others are seeing the same issue over on qt-project as well).

  4. #4
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,355

    Re: CODA no longer working with 701 since system update

    The files are at C:\QtSDK\Symbian\sis\common\CODA and according to the text file that can be found at the same location:
    CODA installer instructions:

    NOTE: Both installers will give same results for using CODA on S60 5th Ed, Anna and Belle.
    The 1.0.6 CODA installer is only added for those that require CODA 4.1.16 working on Symbian code lines not specified above.

    Public-CODA-1.0.5-b2-for-S60v5-Anna-Belle.sis :
    - Contains CODA 4.0.23. Can be used on S60v5, Anna and Belle devices.

    Public-CODA-1.0.6-for-S60v5-Anna-Belle-vFuture.sis :
    - Contains both, CODA 4.0.23(S60v5, Anna and Belle devices) and CODA 4.1.16(For future devices).
    When this installer is used, correct CODA version is selected automatically based on the device in use.
    So the file you should install on device is Public-CODA-1.0.6-for-S60v5-Anna-Belle-vFuture.sis. At install time it will detect Belle FP1 and will install CODA 4.1.16, which should be the correct version.

    If you see an error in the IDE about not being able to debug due to a missing MMP macro, you should update the SDK (online update will do fine) or add the following line to the *.pro file (then run qmake on it):
    Code:
    symbian:MMP_RULES += DEBUGGABLE_UDEBONLY
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  5. #5
    Registered User
    Join Date
    Apr 2012
    Posts
    20

    Re: CODA no longer working with 701 since system update

    I had the same problem with my Nokia 603 FP1, but the reinstallation of CODA and changing the .pro file fixed it. Thanks...

  6. #6
    Registered User
    Join Date
    May 2011
    Posts
    35

    Re: CODA no longer working with 701 since system update

    Ended up picking up another N8 to use during the interim, finally got back to testing on the 701 tonight and to confirm the macro inclusion has solved things for me, thank you Itomuta. It seems with the latest Qt Creator it still needs to be a manual inclusion, at least with previously created project files.

Similar Threads

  1. CODA not working for Carbide C++ 3.3.0 and N97, 5233
    By dauglus in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 3
    Last Post: 2012-03-08, 08:45
  2. Any Widgets which access phone data no longer working, help?
    By JAKE20 in forum Symbian Web Runtime
    Replies: 4
    Last Post: 2012-03-07, 15:58
  3. CODA/USB not working after Anna-update
    By virne in forum [Archived] Qt SDKs and Tools
    Replies: 1
    Last Post: 2011-12-01, 21:12
  4. Organizing source - .pro in-place editor no longer working...
    By rickbsgu in forum [Archived] Qt SDKs and Tools
    Replies: 2
    Last Post: 2010-02-27, 02:24

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •