×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    Apr 2012
    Posts
    24

    [SOLVED]orientation problem during deploy

    Hi, I am testing my mobile game application with a Symbian phone. It works fine whenever I use the emulator but when I tried remote device access I am having problems with the orientation. It should be like this:



    and this is what I got:


    only half the screen is occupied, I believe the phone sees the app as 360x640..

    also tried to remove the landscape lock orientation on the .cpp file, I only got half of the screen filled and the orientation is in portrait. here's my .cpp file:

    Code:
    #include <QtGui/QApplication>
    #include "qmlapplicationviewer.h"
    
    int main(int argc, char *argv[])
    {
        QApplication app(argc, argv);
    
        QmlApplicationViewer viewer;
    
        //this is what I use to lock orientation:
        //viewer.setOrientation(QmlApplicationViewer::ScreenOrientationLockLandscape);
        viewer.setMainQmlFile(QLatin1String("qml/whacko/main.qml"));
        viewer.showExpanded();
    
        return app.exec();
    }
    By the way, I set the base resolution of my QML objects to 640x360; here's the main.qml code:

    Code:
    import QtQuick 1.1
    import com.nokia.symbian 1.1
    import QtMobility.feedback 1.1
    import QtMultimediaKit 1.1
    
    Window {
        id: window
        width: 640
        height: 360
    
        //generalVariables
    
        PageStack {
            id: pageStack
            anchors.fill: parent
        }
    
        Component.onCompleted: {
            pageStack.push(Qt.resolvedUrl("mainScreenView.qml"))
        }
    }
    How can I make the landscape orientation go full screen on a phone? Thanks in advance!

    --------------------------------------------------

    SOLUTION:
    I was previously using a pagestack on the original project. I made a new project with harmattan compatibility so I can have access to the orientation lock function. When the pagestack was still active, the result was the same. But when I removed the pagestack (on the new project) and used the back-end QML as the main page, I was able to get a full screen view of the application
    Last edited by pizarro84; 2012-04-25 at 22:24. Reason: problem solved

  2. #2
    Nokia Developer Champion
    Join Date
    Feb 2008
    Location
    Ahmedabad, Gujarat, India
    Posts
    3,852

    Re: orientation problem during deploy

    hmmm,

    There are two things you can try first one is lock the application in landscape mode only, second is remove the width and height of the window, i guess Window component is clever enough to understand its width and height.

  3. #3
    Registered User
    Join Date
    Apr 2012
    Posts
    24

    Re: orientation problem during deploy

    Hi, yeah I just recently tried to remove the width and height of the window and did an 'anchors.fill: parent' on the main.qml and all succeding qmls, and I also locked the orientation. I still get the same results as I posted..


    Edit: By the way, the one on the colored screen is from the emulator..

  4. #4
    Registered User
    Join Date
    Apr 2012
    Posts
    24

    Re: [SOLVED]orientation problem during deploy

    SOLUTION:
    I was previously using a pagestack on the original project. I made a new project with harmattan compatibility so I can have access to the orientation lock function. When the pagestack was still active, the result was the same. But when I removed the pagestack and used the back-end QML as the main page, I was able to get a full screen view of the application. By the way, the back-end QML's root Item is a Page.

Similar Threads

  1. Deploy App - Problem
    By awdrenfontao in forum Nokia Asha Web Apps
    Replies: 5
    Last Post: 2011-07-18, 08:11
  2. CSenServiceConnection connection problem when deploy on phone
    By rvikesh in forum Symbian Networking & Messaging (Closed)
    Replies: 4
    Last Post: 2010-01-21, 12:57
  3. Nokia Developer's Suite 2.0 , deploy problem
    By tenfire in forum Mobile Java Tools & SDKs
    Replies: 0
    Last Post: 2003-09-30, 18:50
  4. OTA deploy problem from applications with record stores
    By mpadberg in forum Mobile Java General
    Replies: 0
    Last Post: 2002-12-10, 13:40

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×