×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    Dec 2007
    Posts
    43

    WRT Widgets won't work on Belle FP1?

    Some complained the WRT widgets can't retrieve content back after upgraded to Belle FP1, my handset is N8, that is not able to upgrade to Belle FP1 so I can't test and check, whether it is due to no Internet access or XmlHttpRequest behaves differently on FP1.

    These WRT widgets work just fine in S60, Symbian^3, Anna and Belle, now stop at Belle FP1.

    Anyone has similiar issue?

  2. #2
    Nokia Developer Moderator
    Join Date
    Jun 2008
    Location
    Tampere
    Posts
    833

    Re: WRT Widgets won't work on Belle FP1?

    Hi,

    Maybe you could check the widget in Belle FP1 device by using Remote Device Access?

    Br,
    Ilkka

  3. #3
    Registered User
    Join Date
    Dec 2007
    Posts
    43

    Re: WRT Widgets won't work on Belle FP1?

    Tried Belle FP1 via Remote Device Access, it indeed didn't work... :-(

    But I figured out where the problem came from, looks like FP1's bug on Javascript RegExp.

    For example:

    // convert "USDEUR=X" => EUR
    str = '"USDEUR=X"';
    regExp = eval('/"USD|=X"/gs');
    result = str.replace(regExp, '');
    // Expteced result = "EUR";

    The above works for S60, Symbian^3, Anna and Belle, but no longer works for Belle FP1.

    As a workaround, I have to replace 2 times without using RegExp
    result = str.replace('"USD', '');
    result = result.replace('=X"', '');

    The workaround works on Belle FP1 via Remote Device Access.

Similar Threads

  1. How to develop Belle Home Screen widgets
    By hissorrow in forum Symbian
    Replies: 12
    Last Post: 2013-04-26, 13:43
  2. App not work to Belle?
    By jaso80 in forum Publishing to Nokia Store
    Replies: 4
    Last Post: 2012-04-02, 22:24
  3. Symbian C++ Widgets and "Widgets to offline mode"
    By stevecluk in forum Symbian User Interface
    Replies: 1
    Last Post: 2011-11-16, 13:45
  4. WRT widgets do not work on S60 5th emulator and Symbian^3 emulator on Vista
    By sh2sg in forum Tools and SDK Feedback (Closed)
    Replies: 2
    Last Post: 2010-12-08, 11:23

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •