×

Discussion Board

Results 1 to 5 of 5
  1. #1
    Registered User
    Join Date
    Jan 2012
    Posts
    22

    [moved] Starting QProcess with arguments (paramaters)

    Hello.

    Hello, I tried:

    Code:
        QProcess proc1;
        QStringList str1;
        str1.append("x1");
        str1.append("x2");
        proc1.setNativeArguments(arguments); // there is no QProcess:setArguments for me :(
        proc1.start();
    The error message:
    no matching function for call to 'QProcess::setNativeArguments(QStringList&)'

    Someone to help me?

    Thank you
    Last edited by pascal95abc; 2012-04-24 at 15:30.

  2. #2
    Registered User
    Join Date
    Sep 2011
    Posts
    449

    Re: [moved] Starting QProcess with arguments (paramaters)

    the setNativeArguments method takes QString as parameter and not the list.
    so if there are multiple arguments you can mention like this

    proc1.setNativeArguments("x1 x2");

  3. #3
    Registered User
    Join Date
    Jan 2012
    Posts
    22

    Re: [moved] Starting QProcess with arguments (paramaters)

    Hello.
    Thank you, this is now clear how to pass arguments.

    Do you know what is the string I have to pass in QProcess.start(??) ? Is it the app name displayed in the programs menu or the uid or ... ? I had some issues with it.

  4. #4
    Nokia Developer Champion
    Join Date
    Feb 2008
    Location
    Ahmedabad, Gujarat, India
    Posts
    3,852

    Re: [moved] Starting QProcess with arguments (paramaters)

    i am not sure but it can be location of exe which actually starts some process. Or a command if its on Meego

  5. #5
    Registered User
    Join Date
    Jan 2012
    Posts
    22

    Re: [moved] Starting QProcess with arguments (paramaters)

    Ok, this is good.
    Thanks for help

Similar Threads

  1. [moved] Message box on first starting of carbid c++
    By mind_freak in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 5
    Last Post: 2009-06-25, 08:23
  2. [moved] Problem with starting application
    By paintstripper in forum Symbian
    Replies: 16
    Last Post: 2008-09-22, 19:44
  3. [moved] D_EXC Leave-1 Panics when starting on N82
    By dzanter in forum Symbian Tools & SDKs
    Replies: 6
    Last Post: 2008-07-03, 03:40

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •