×

Discussion Board

Results 1 to 6 of 6
  1. #1
    Registered User
    Join Date
    Jul 2008
    Posts
    103

    Angry Device not supported error in compiling for 3rd edition

    As I am stupid enough to still develop for Symbian and idiot enough to target for 3rd edition with Qt, I have the following problem regarding Smart Installer:

    - I am compiling an application for 3rd edition
    - I am using Qt SDK 1.1.2 since Nokia decided to remove all 3rd edition support from 1.2.x
    - If I install manually Qt 4.6.3 and Qt Mobility 1.0.2, my application can be installed/updated and it works
    - If I create Smart installer package and try to install it on a 3rd edition phone such as C5 (note to Nokia: these phones are still quite popular, especially among older users and users which don't like touchscreens) I get "Device not supported" error
    - Target is of course Qt 4.6.3 for Symbian^1 since in Qt SDK 1.1.2 I did not find an explicit target for 3rd edition

    Questions:
    - How do I make smart installer install Qt and my app on 3rd edition phones? (i.e. DOING WHAT IT'S SUPPOSED TO DO)
    - If I need older SDK for that, where do I download it from and which location, since the qtsdk folder in ftp://ftp.qt.nokia.com/ cannot be accessed?

  2. #2
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: Device not supported error in compiling for 3rd edition

    Hi catharsis,

    The Smart Installer has as first priority to support delivery of Qt apps to Nokia Store supported devices, but it should in fact support at Qt compatible devices, including the Nokia C5-00. That being said, it could be that the device (or a variant of it) is missing from Smart Installer's configuration.

    Can you please enable the smart installer logs ( see "How to get help?" at http://nokia.ly/SmartInstaller ) and show us the content of the bootlog.txt? Once we understand exactly what is missing we should be able to fix the problem.
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  3. #3
    Registered User
    Join Date
    Jul 2008
    Posts
    103

    Re: Device not supported error in compiling for 3rd edition

    Hello Lucian, first of all, sorry for the tone of my message, but I become more and more frustrated by the lack of support from Nokia for Qt for 3rd edition devices and also the app was trying to install was a camera implementation using native Symbian methods, since QtMobility 1.0.2 (or which one is it in Qt 4.6.3) does not have QCamera and Qt 4.7.3 does not officially support 3rd edition (which is also baffling to me as: 1. forcing the installation of Qt 4.7.3 and QtMobility 1.1.3 works on 3rd edition phones and apps compiled for 5th edition are working also in 3rd if you ignore "application not compatible warnings" and 2. It would of been nice from Nokia to actually release a QtMobility package with QCamera which works also in 3rd edition, not just abandon it, although I realize that 4.7.3 is not supported probably because of Qt Quick).

    The phone I was tesing is actually a C5-02, here are the logs:
    log-boot.txt http://pastebin.com/UdYGV8uU
    log.txt http://pastebin.com/N0BDwFDJ

  4. #4
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: Device not supported error in compiling for 3rd edition

    Hi catharsis, I understand your frustration, but Nokia too had to make decisions about where to spend R&D resources and by now the Qt situation is clear, there's no backport to be expected for any of the components unless it is community driven.

    Your logs are useful, we are indeed dealing with a variant of C5-00 that is pretty much off the main stream map. But it was reported as not supported by Smart Installer already in http://www.developer.nokia.com/Commu...ta-data-update, now I have to chase it down again and see why the configuration was not updated. I'll come back with news as soon as I have any.
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  5. #5
    Registered User
    Join Date
    Jul 2008
    Posts
    103

    Re: Device not supported error in compiling for 3rd edition

    Yes, Nokia decisions are somehow understandable, especially in the context that Symbian is not the primary OS anymore. What I don't fully understand is why Qt 4.7.3 and QtMobility 1.1.3 do not support 3rd edition since they appear to function without problems (I suppose Nokia did not have enough resources/interest to test them on 3rd edition or it was because of QtQuick). And I mistaken the phone version, it's C5-00.02, which probably is now the only or main C5 you find in shops. Thank you for your patience and quick answers.

  6. #6
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: Device not supported error in compiling for 3rd edition

    Try now please, the device should have been added already (but it may take some time to propagate all around the world).
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

Similar Threads

  1. 'System Error' in S60 3rd Edition device.
    By dilipsinh in forum Symbian
    Replies: 7
    Last Post: 2012-02-28, 11:09
  2. Replies: 5
    Last Post: 2010-10-13, 13:34
  3. compiling error with S40 5th edition library
    By morningai in forum Mobile Java General
    Replies: 7
    Last Post: 2007-11-29, 16:09
  4. S60 3rd edition, compiling for target device
    By Jeepy in forum Symbian Tools & SDKs
    Replies: 5
    Last Post: 2006-08-16, 09:57

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×