×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Super Contributor
    Join Date
    Nov 2010
    Posts
    1,261

    Cool Today I have installed Nokia_Belle_SDK_v1.0 but facing problems with the perl path.

    I have installed Nokia_Belle_SDK_v1.0 which came with Active perl 5.89 Build 635 but I uninstaled


    the earleir versions and installed ActivePerl-5.6.1.635-MSWin32-x86.msi accroding to the Relaease notes given in the SDK.


    When I compile any application with Bele SDK iamgetting the folowing error as below




    Can't locate E32env.pm in @INC (@INC contains: C:\Symbian\Nokia_Symbian_Belle_SDK_v1.0\epoc32\tools\ C:/Perl/lib C:/Perl/site/lib .) at C:\Symbian\Nokia_Symbian_Belle_SDK_v1.0\epoc32\tools/bldmake.pl line 37.
    BEGIN failed--compilation aborted at C:\Symbian\Nokia_Symbian_Belle_SDK_v1.0\epoc32\tools/bldmake.pl line 37.

  2. #2
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,737

    Re: Today I have installed Nokia_Belle_SDK_v1.0 but facing problems with the perl p


  3. #3
    Super Contributor
    Join Date
    Nov 2010
    Posts
    1,261

    Re: Today I have installed Nokia_Belle_SDK_v1.0 but facing problems with the perl p

    Iam not getting you please give the exact solution.

    Tell me one thing Why this problem exists for Belle SDK only where as other SDK's give no problem.


    which one to select when Iam buliding a project now SBSV1 or SBSV2 ?

    Now the Active perl I used is 5.61 build 635 and localetd in C: drive

  4. #4
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,737

    Re: Today I have installed Nokia_Belle_SDK_v1.0 but facing problems with the perl p

    Quote Originally Posted by GTO_India View Post
    Iam not getting you please give the exact solution.
    It was a question, not a solution.
    Tell me one thing Why this problem exists for Belle SDK only where as other SDK's give no problem.
    SBS=Symbian Build System. Symbian Belle has no support for the first version, "SBSv1", so the old "bldmake bldfiles", "abld build" commands. It has a number of "sbs" commands instead, as it is shown in the first link.
    It also applies to Carbide.c++. Even if it allows selecting any of the two (Carbide.c++ v2.7 may allow that), you have to select SBSv2.
    which one to select when Iam buliding a project now SBSV1 or SBSV2 ?
    2
    Now the Active perl I used is 5.61 build 635 and localetd in C: drive
    That should be fine.

Similar Threads

  1. How to konw which path the app installed?
    By sundy10 in forum Symbian
    Replies: 5
    Last Post: 2009-11-06, 07:52
  2. Cardbide 2.0 perl was not found on your PATH
    By afk009 in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 8
    Last Post: 2009-08-27, 20:51
  3. Help determine the the installed path
    By stevenc9 in forum Symbian
    Replies: 5
    Last Post: 2009-05-27, 09:30
  4. Problems we are facing with Carbide C++. Please help with the solutions
    By bharath_hegde in forum Symbian Tools & SDKs
    Replies: 2
    Last Post: 2006-11-15, 18:22

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×