×

Discussion Board

Results 1 to 6 of 6
  1. #1
    Registered User
    Join Date
    May 2012
    Posts
    2

    Question Develop for S60v5 with QtQuick Components

    Hi, I want to port my app from symbian^3 to s60v5. My App was developer with Qt SDK 1.2 using Qt Quick Components version 1.1, but Qt Quick Components version 1.1 doesn't exist to s60v5, I knew the version 1.0 of Qt Quick Components is supported by s60v5, but I could not found. The Qt Quick Components 1.1 package includes both Qt Quick Components versions 1.0 and 1.1.

    How can I used the Qt Quick Components for develop in S60v5?

  2. #2
    Super Contributor
    Join Date
    Jun 2006
    Location
    India
    Posts
    3,037

    Re: Develop for S60v5 with QtQuick Components

    Instead of importing 1.1 version import 1.0 version and build your app. What ever error comes remove those error.
    Use [URL="http://qt.nokia.com/products/qt-quick/"]Qt-Quick[/URL] to make your application UI more attractive.

    [URL="http://store.ovi.com/content/271896"]http://store.ovi.com/content/271896[/URL] | [URL="http://store.ovi.com/content/276199"]http://store.ovi.com/content/276199[/URL] |[URL="http://store.ovi.com/content/276202"] http://store.ovi.com/content/276202[/URL] | [URL="http://store.ovi.com/content/280827"]http://store.ovi.com/content/280827[/URL]

  3. #3
    Registered User
    Join Date
    May 2012
    Posts
    2

    Re: Develop for S60v5 with QtQuick Components

    Compile without errors, but when I open the app in my mobile (C5-03) the screen only turn black, then I press the home button and close the application... in other words, my application don't work :'(...

    P.S. I use smart installer

  4. #4
    Super Contributor
    Join Date
    Jun 2006
    Location
    India
    Posts
    3,037

    Re: Develop for S60v5 with QtQuick Components

    there might be element or property you have used in qml file, which is not available in 1.0. check on simulator, what is happening?
    Use [URL="http://qt.nokia.com/products/qt-quick/"]Qt-Quick[/URL] to make your application UI more attractive.

    [URL="http://store.ovi.com/content/271896"]http://store.ovi.com/content/271896[/URL] | [URL="http://store.ovi.com/content/276199"]http://store.ovi.com/content/276199[/URL] |[URL="http://store.ovi.com/content/276202"] http://store.ovi.com/content/276202[/URL] | [URL="http://store.ovi.com/content/280827"]http://store.ovi.com/content/280827[/URL]

  5. #5
    Nokia Developer Champion
    Join Date
    Feb 2008
    Location
    Ahmedabad, Gujarat, India
    Posts
    3,852

    Re: Develop for S60v5 with QtQuick Components

    just to interrupt ,

    i think Qt Quick Components are not supported by S60 v5 in Qt SDK 1.2. You might need to use the old sdk.

    And its recommended not to use Qt Quick Components with S60v5 , please correct me if i am wrong.

  6. #6
    Registered User
    Join Date
    Sep 2011
    Location
    Moscow, Russian Federation
    Posts
    19

    Re: Develop for S60v5 with QtQuick Components

    Qt Quick Components are not available for S60v5 out of box. Nevertheless I just shared sources of the sample application on Google Code here, which will demonstrate you, how to bring the power of them to S60 5th edition platform too. The key idea is to build them from sources and then embed into Symbian installer as Qt Quick plugins.

Similar Threads

  1. Cannot develop app using Qt Quick Components in QT SDK 1.1.4
    By shintu in forum [Archived] Qt SDKs and Tools
    Replies: 2
    Last Post: 2012-01-18, 11:04
  2. Is there a QtQuick / components roadmap?
    By tube42 in forum [Archived] Qt Quick
    Replies: 5
    Last Post: 2011-09-09, 21:36
  3. QtQuick 1.1 available?? Help please
    By lukakiarelli in forum [Archived] Qt Quick
    Replies: 4
    Last Post: 2011-06-21, 07:01
  4. conversion from s60v5 to s60v5
    By yahoo2010 in forum Symbian
    Replies: 3
    Last Post: 2011-01-31, 03:09

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×