×

Discussion Board

Results 1 to 4 of 4

Hybrid View

  1. #1
    Registered User
    Join Date
    Oct 2011
    Posts
    76

    Exclamation Qt not deploying, giving libqt4 error

    hi m8,

    when i try to deploy speech2text (simon) application on my pc, qt gave many errors. please help me for that.

    Compile Output

    dpkg-shlibdeps: warning: symbol __aeabi_idiv@GCC_3.5 used by debian/simone/opt/simone/bin/simone found in none of the libraries.
    dpkg-shlibdeps: warning: symbol __aeabi_unwind_cpp_pr1@GCC_3.5 used by debian/simone/opt/simone/bin/simone found in none of the libraries.
    dpkg-shlibdeps: warning: symbol __aeabi_uidiv@GCC_3.5 used by debian/simone/opt/simone/bin/simone found in none of the libraries.
    dpkg-shlibdeps: warning: symbol __aeabi_uidivmod@GCC_3.5 used by debian/simone/opt/simone/bin/simone found in none of the libraries.
    dpkg-shlibdeps: warning: symbol __aeabi_unwind_cpp_pr0@GCC_3.5 used by debian/simone/opt/simone/bin/simone found in none of the libraries.
    dpkg-shlibdeps: warning: dependency on libgcc_s.so.1 could be avoided if "debian/simone/opt/simone/bin/simone" were not uselessly linked against it (they use none of its symbols).
    dpkg-shlibdeps: warning: dependency on libQtOpenGL.so.4 could be avoided if "debian/simone/opt/simone/bin/simone" were not uselessly linked against it (they use none of its symbols).
    dpkg-shlibdeps: warning: dependency on libGLESv2.so could be avoided if "debian/simone/opt/simone/bin/simone" were not uselessly linked against it (they use none of its symbols).
    dpkg-shlibdeps: warning: dependency on libQtMultimedia.so.4 could be avoided if "debian/simone/opt/simone/bin/simone" were not uselessly linked against it (they use none of its symbols).
    dpkg-shlibdeps: warning: dependency on libpthread.so.0 could be avoided if "debian/simone/opt/simone/bin/simone" were not uselessly linked against it (they use none of its symbols).
    dpkg-gencontrol: warning: unknown substitution variable ${miscepends}

    dh_md5sums
    dh_builddeb
    aegis-manifest: Creating 'simone.aegis'.
    dpkg-genchanges -b -u.. >../simone_0.0.1_armel.changes
    dpkg-buildpackage: binary only upload (no source included)
    dpkg-genchanges: binary-only upload - not including any source code
    20:42:35: Package Creation: Running command 'c:/qtsdk/madde/bin/mad dh_clean'.
    20:42:37: Package created.
    20:42:37: Installing package to sysroot ...
    Package 'simone' removed.

    Package 'simone' installed.

    20:42:38: Connecting to device...
    20:42:39: Preparing SFTP connection...
    20:42:39: Starting upload...
    20:42:39: Successfully uploaded package file.
    20:42:39: Installing package to device...
    (Reading database ... 48335 files and directories currently installed.)
    Preparing to replace simone 0.0.1 (using /tmp/simone_0.0.1_armel.deb) ...
    Unpacking replacement simone ...
    aegis-installing simone (from '')
    dpkg: dependency problems prevent configuration of simone:
    simone depends on libqt4-multimedia (>= 4.7.4~git20110517); however:
    Package libqt4-multimedia is not installed.
    dpkg: error processing simone (--install):
    dependency problems - leaving unconfigured

    Processing triggers for desktop-file-utils ...
    Processing triggers for hicolor-icon-theme ...
    Errors were encountered while processing:
    simone
    20:42:53: Installing package failed.
    20:42:53: Deploy step failed.
    Error while building project simone (target: Harmattan)
    When executing build step 'Deploy Debian package via SFTP upload'

  2. #2
    Registered User
    Join Date
    Sep 2011
    Posts
    449

    Re: Qt not deploying, giving libqt4 error

    Hi,

    In your .pro file, please add

    CONFIG+= mobility
    MOBILITY = multimedia

    and remove
    QT += multimedia

    the it should search for the existing libqtm-multimedia and not the libqt4-multimedia

    Let me know if this solves your problem

    Edit: You might also have to change the header files to use from qt mobility
    Last edited by kusumk; 2012-05-07 at 05:22.

  3. #3
    Registered User
    Join Date
    Oct 2011
    Posts
    76

    Re: Qt not deploying, giving libqt4 error

    thanks for ur reply @kusumk.
    i solved this problem.

    i added "#include <QObject>" in my soundinput.cpp file (i have used <QAudioInput> etc. class). so i deployed success.

    best regards.

  4. #4
    Registered User
    Join Date
    Nov 2010
    Posts
    9

    Re: Qt not deploying, giving libqt4 error

    Quote Originally Posted by prodigy47 View Post
    thanks for ur reply @kusumk.
    i solved this problem.

    i added "#include <QObject>" in my soundinput.cpp file (i have used <QAudioInput> etc. class). so i deployed success.

    best regards.
    Thank you, a combination of both solutions worked for me!

Similar Threads

  1. GPS problem..giving an error
    By poojs in forum Mobile Java General
    Replies: 4
    Last Post: 2009-09-01, 12:53
  2. Adding Rms in S60 giving error
    By ansh.chauhan in forum Mobile Java Tools & SDKs
    Replies: 3
    Last Post: 2009-05-04, 08:21
  3. TC-ConvertP12 giving error
    By Prexa in forum Symbian Signed Support, Application Packaging and Distribution and Security
    Replies: 5
    Last Post: 2008-07-08, 08:06
  4. HTTPClient giving error:-33
    By vvsnaresh in forum Symbian
    Replies: 0
    Last Post: 2005-10-19, 13:22
  5. My udp server giving error
    By sri_nainala in forum Symbian Networking & Messaging (Closed)
    Replies: 0
    Last Post: 2004-12-03, 11:13

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×