×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    Aug 2010
    Posts
    6

    Question no service found for - "com.nokia.qt.radio"

    When an run the radio example on N9,
    I got this error:

    defaultServiceProvider::requestService(): no service found for - "com.nokia.qt.radio"

    Any solutions for this?

    Thanks!
    zhxt

  2. #2
    Registered User
    Join Date
    Sep 2011
    Posts
    449

    Re: no service found for - "com.nokia.qt.radio"

    Support for QSystemInfo::FmTransmitterFeature is FALSE

    Did anybody check how FMRX (fm radio app) works on N9..

  3. #3
    Registered User
    Join Date
    Aug 2010
    Posts
    6

    Re: no service found for - "com.nokia.qt.radio"

    kusumk: Yes, you're right.
    info.hasFeatureSupported(QSystemInfo::FmTransmitterFeature) returned false;

    But the the doc says: FM Radio transmitter available. Since 1.2;
    I already have v1.2 firmware installed


    I found that the app FM Radio N9 uses a fmradio-backend as a seprate process.
    May it's a lower layer api on /dev/radio.

  4. #4
    Registered User
    Join Date
    Sep 2011
    Posts
    449

    Re: no service found for - "com.nokia.qt.radio"

    some more links

    http://forum.meego.com/showthread.php?t=3902&page=3

    http://talk.maemo.org/showthread.php?t=82943

    even i was confused of the receiver and transmitter for a minute..

Similar Threads

  1. qmediaplayer no service found for - "com.nokia.qt.mediaplayer"
    By oruccim in forum [Archived] Qt Mobility Project
    Replies: 7
    Last Post: 2012-07-06, 08:46
  2. Replies: 2
    Last Post: 2010-11-29, 02:29
  3. Nokia Forum - "Unable to load data" on N79 if xml not found or not loaded
    By supriyaakg in forum [Archived] Flash Lite on Nokia Devices
    Replies: 3
    Last Post: 2010-04-15, 07:58

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×