×

Discussion Board

Results 1 to 5 of 5

Hybrid View

  1. #1
    Registered User
    Join Date
    May 2012
    Posts
    2

    Question Problem with IAPClient::getProductData in "simulation" mode

    Hi,
    I found a problem when I make a call IAPClient::getProductData in "simulation" mode and when signal productDataReceived is emitted, it contains wrong requestId. RequestId value is 2 instead of the "requested" one. Is this expected behavior?

    I'm using Qt API for IAPClient.

    Thanks, Saso
    Last edited by sasosecnjak; 2012-05-29 at 11:48.

  2. #2
    Nokia Developer Expert
    Join Date
    Sep 2011
    Posts
    382

    Re: Problem with IAPClient::getProductData in "simulation" mode

    Hi,

    It is known issue with certain version of the In App Purchase API, phone client could be updated using smart installer to install an application using that API and that assumed to fix this problem.

    /0
    Last edited by Devnull; 2012-05-31 at 14:18.

  3. #3
    Registered User
    Join Date
    May 2012
    Posts
    2

    Re: Problem with IAPClient::getProductData in "simulation" mode

    Thanks for your reply,

    I'm already using smart installer and is set to use In App Purchase API package version 3.23.007, and I think this is currently the newest one.

    Saso

  4. #4
    Registered User
    Join Date
    Nov 2009
    Posts
    15

    Re: Problem with IAPClient::getProductData in "simulation" mode

    I've the same version of IAP and I've some problem with the requestId. I'm running multiple parallel requests from the same IAPClient (six requests, I have 6 products). productDataRecived is emitted multiple times but the requestId is always the same. Is this the expected behaviour?

  5. #5
    Nokia Developer Expert
    Join Date
    Oct 2007
    Posts
    441

    Re: Problem with IAPClient::getProductData in "simulation" mode

    Hi

    API package version 3.23.007 is included to IAP SDK and does contain error : request Id mismatches response. Smart Installer server offers version 3.23.10 where this problem is fixed

    Please make your application build with Smart Installer and check the problem is gone.

Similar Threads

  1. Key(s) Simulation "Globally"
    By ssn.kishore in forum Symbian
    Replies: 18
    Last Post: 2008-10-08, 07:23
  2. Replies: 1
    Last Post: 2005-05-11, 18:16
  3. Keypad input mode "Abc" and "123"
    By fafou in forum Symbian
    Replies: 0
    Last Post: 2003-06-23, 09:59
  4. Replies: 1
    Last Post: 1970-01-01, 02:00

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×