×

Discussion Board

Results 1 to 15 of 15
  1. #1
    Registered User
    Join Date
    Jun 2012
    Posts
    15

    Application Not running On Device

    Hey.

    I am trying to get the position of the device e72 by using Qt SDK 4.6.3 with mobility 1.0.2. My device compiles perfectly on the computer and after i get the sis file signed and install it on my device, the application does not open on the device. There is no error message during installation
    plus i also added the following code to my .pro file:

    config += mobility
    mobility += location

    symbian: TARGET.CAPABILITY += NetworkServices Location


    Why is the application not running on device???

  2. #2
    Nokia Developer Expert
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,142

    Re: Application Not running On Device

    likely it is actually running, but also crashing during construction, so catch the panic code for the crash: http://www.developer.nokia.com/Commu...ded_panic_code

  3. #3
    Registered User
    Join Date
    Mar 2011
    Posts
    16

    Re: Application Not running On Device

    Have you installed dependencies (Qt and QtMobility versions) on the device?

  4. #4
    Registered User
    Join Date
    Jun 2012
    Posts
    15

    Re: Application Not running On Device

    Yes the .sis file for Qt Mobility version 1.0.2 is downloaded on the device

  5. #5
    Nokia Developer Expert
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,142

    Re: Application Not running On Device

    not just that, you basically would need to also install the Qt sis files there..

  6. #6
    Registered User
    Join Date
    Jun 2012
    Posts
    15

    Re: Application Not running On Device

    i have installed the sis files there. i am using Qt mobility 1.0.2 and while searching the reason for the application not opening, i came across this article
    http://labs.qt.nokia.com/2010/07/01/...-nokia-qt-sdk/

    Has it got something to do with this? i really doubt it as it would have been updated by now. Please let me know. Thanks

  7. #7
    Nokia Developer Expert
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,142

    Re: Application Not running On Device

    Just make sure you have installed all required sis files into the device, and make sure they are made for the platform version you are using.

    And then check the panic code as suggested in #2.

  8. #8
    Registered User
    Join Date
    Jun 2012
    Posts
    15

    Re: Application Not running On Device

    i checked the link you had posted. The thing is i use Qt simulator on my for simulation of the code. IS there any other way to check the panic code?

  9. #9
    Registered User
    Join Date
    Mar 2011
    Posts
    16

    Re: Application Not running On Device

    Can you please paste the content of .pkg file of your application?

    Are you using nokia Qt SDK? If yes then please see this link: http://bugreports.qt.nokia.com/brows...mment-tabpanel

    If not then please let me know your build environment.

  10. #10
    Registered User
    Join Date
    Jun 2012
    Posts
    15

    Re: Application Not running On Device

    i am using nokia Qt SDK 4.6.3 with mobility version 1.0.2 and i have installed the same versions on my device E72 with OS s60 3rd edition FP2

  11. #11
    Registered User
    Join Date
    Jun 2012
    Posts
    15

    Re: Application Not running On Device

    the contents of my .pkg file are pasted below::::



    ; GPSCheck_installer.pkg generated by qmake at 2012-06-04T16:58:27
    ; This file is generated by qmake and should not be modified by the user
    ;

    ; Language
    &EN


    ; SIS header: name, uid, version
    #{"GPSCheck installer"},(0xA000D7CE),1,0,0

    ; Localised Vendor name
    %{"Vendor"}

    ; Unique Vendor name
    :"Vendor"


    ; Manual PKG pre-rules from PRO files
    ; Default dependency to Qt libraries
    ; Default HW/platform dependencies
    [0x101F7961],0,0,0,{"S60ProductID"}
    [0x102032BE],0,0,0,{"S60ProductID"}
    [0x102752AE],0,0,0,{"S60ProductID"}
    [0x1028315F],0,0,0,{"S60ProductID"}
    [0x20022E6D],0,0,0,{"S60ProductID"}

    ; Default dependency to QtMobility libraries


    "C:/Qt4.6.3/QtCreator/bin/GPSCheck/GPSCheck.sis" - "c:\private\2002CCCE\import\GPSCheck.sis"
    @"C:/Qt4.6.3/Symbian/SDK/smartinstaller.sis",(0x2002CCCD)

  12. #12
    Registered User
    Join Date
    Mar 2011
    Posts
    16

    Re: Application Not running On Device

    Hi,
    As per the bug report, mentioned in #9 : “Nokia Qt SDK not backwards compatible with S60 3rd edition FP1 and FP2 (integer division)”
    So I suggest you to use separate Qt 4.6.3 version with S60 FP2 sdk to build your application.

    Let me explain you the Build set up for your application.

    Step 1: You need to Install Symbian S60 3.2 SDK. From :
    http://www.forum.nokia.com/info/sw.n..._One_SDKs.html

    After Install Please make sure that the SDK is up and running.Make sure that before SDK installation Perl & Java is also installed on your machine.

    Step 2: Install Qt SDK for Symbian from
    http://get.qt.nokia.com/qt/source/ qt-symbian-opensource-4.7.1-s60.exe

    Please select S60 3.2 SDK when it asks during Installation time.

    Step 3: Install Open C Plugin.

    Stepl 4: Install Qt Mobility from
    http://download.qt.nokia.com/qt/solutions/

    Mobililty installation is bit different. First we need to extract the zip files in temporary folder. Inside that you will get pre built binaries for S60 3.2 as a zip file. example "qt-mobility-1.0.0-epoc32-3.2.zip"
    You need to extract this on top of the S60 3.2 SDK root folder.
    once it is done. You have to configure mobility as mentioned in previous post.

    Step 5: Now you can open Qt Creator for your project and select S60 3.2 SDK as the Target. Basically what is tells that : "Use the Qt Libraries and Symbian libraries from the 3.2 SDK env" and compile the App.

    I hope this should solve your problems. Let us know if you have any issues.

  13. #13
    Registered User
    Join Date
    Mar 2011
    Posts
    16

    Re: Application Not running On Device

    One more suggestion , use correct certificate to sign your app. because this also may be the reason.
    And also check whether your certificate have required capabilities or not.

  14. #14
    Registered User
    Join Date
    Jun 2012
    Posts
    15

    Re: Application Not running On Device

    Hey

    I did everything that you told me exactly in the same way but i got stuck at two places,
    1. Installing Qt Mobility: i installed version 1.1.0 an then extracted it to the temporary folder as you had suggested, this thing is that i could not find binaries for s60 there. infact i searched and there was no zip file present in the complete folder that i extracted.
    2. I already have Qt SDK 4.6.3 through which i run Qt creator. The thing is that here it gives me errors in the file qstring.h. IS this because of the older version of Creator

    Also it would be really helpful if i you could tell me about the path extension i need to give in the environment variables after i install Qt Mobility.

    Thanks

  15. #15
    Registered User
    Join Date
    Jun 2012
    Posts
    15

    Re: Application Not running On Device

    and when i am running my application using the s60 SDK it is showing errors in the qstring.h and qvector.h files, which i haven't even changed....

Similar Threads

  1. Signed Application is running in S40 device but not on S60 device
    By senthil_25 in forum Mobile Java General
    Replies: 5
    Last Post: 2011-04-12, 05:53
  2. Running Qt application on device
    By Maysoon88 in forum Qt
    Replies: 7
    Last Post: 2010-11-24, 07:50
  3. Application running on emulator but not running on Device
    By syedshakeel2004 in forum Symbian Signed Support, Application Packaging and Distribution and Security
    Replies: 3
    Last Post: 2010-09-28, 13:55
  4. Application Error While running application in real device
    By praveen_bluebird in forum Mobile Java General
    Replies: 4
    Last Post: 2006-11-21, 04:39

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •