×

Discussion Board

Results 1 to 2 of 2
  1. #1
    Registered User
    Join Date
    Jan 2012
    Posts
    12

    Nokia Java SDK 1.1 emulator security domain settings when debugging.

    Hi,

    I'm using Nokia SDK for Java 1.1 to debug my java application. The application uses the filesystem and contacts the internet so I have set the emulator security domain setting to maximum. When I run the application in emulator it works ok. No security dialogs pop-up or anything.
    But when I run the same application in the debugging mode it seems that the emulator reverts back to minimum security domain and I have to click hundreds of security dialogs. When I go to emulator Tools > Preferences > MIDP tap the security domain is in Maximum, but it doesn't have any effect.

    Is this a bug or am I doing something wrong?

    I'm using Windows 7 and Eclipse Pulsar.

  2. #2
    Nokia Developer Expert
    Join Date
    May 2012
    Location
    Espoo
    Posts
    224

    Re: Nokia Java SDK 1.1 emulator security domain settings when debugging.

    Hello mikkori and welcome to the Nokia discussion board,

    Alternative solution would be debug your application with sun wireless toolkit or oracle JavaMe sdk.

    Security dialogs pop-up can be get ride by launching your application in eclipse pulsar by right click on the project -->Debug As --> Debug configurations.. -->on right side select emulation tab --> select ‘trusted’ in Security domain section.

Similar Threads

  1. Issuer Security Domain
    By esunilkumare in forum Near Field Communication
    Replies: 9
    Last Post: 2008-05-26, 13:17
  2. S60 3rd emulator does not recognize security domain settings
    By neil.young in forum Mobile Java Tools & SDKs
    Replies: 3
    Last Post: 2008-02-15, 23:13
  3. security domain for PIM
    By yasmeen302004 in forum Mobile Java General
    Replies: 1
    Last Post: 2008-01-08, 16:01
  4. Replies: 0
    Last Post: 2003-06-05, 21:09
  5. Replies: 1
    Last Post: 2003-05-08, 09:17

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×