×

Discussion Board

Page 1 of 2 12 LastLast
Results 1 to 15 of 19
  1. #1
    Registered User
    Join Date
    Mar 2012
    Posts
    24

    Does the qtmobility's gsensor have problem?

    Does the newest qtmobility's gsensor have problem??
    The old qtmobility's sensors/accel sample now not include in qtmobility.
    And I test accel and it has problem.

    The following is the description. Do I need rollback to old version or it has another good method?

    2012/05/08, I update the QtSdk to revision 8cd370e163. (Till now 2012-06-19, the newst qt version is the same.)
    I find that qtmobility's sensors/accel sample cannot run on my Nokia 700 phone. But it can run on my C7-00 phone.
    Before updates, the two phones all can work.

    Error message in CODA:
    Executable file: 6259 2012-05-08T21:09:10 C:\QtSDK\Symbian\SDKs\SymbianSR1Qt474\\epoc32\release\armv5\urel\accel.exe
    Connecting to 192.168.11.4:1534...
    Connected.
    Launching: accel.exe
    Launch failed: Command answer [command error], 1 values(s) to request: 'C|4|Processes|start|""|"accel.exe"|[""]|[]|true'
    #0 {"Code":-5,Format="Failed to create the process (verify that the executable and all required DLLs have been transferred) (functionality is not supported)"}
    Error: 'Failed to create the process (verify that the executable and all required DLLs have been transferred) (functionality is not supported)' Code: -5
    Finished.

    Error message on phone: "Home screen: Feature not supported". (PS: this message seems happen in Janurary)

    The following is the phone model=>

    Nokia C7-00 phone:
    Release: Symbian Belle
    Software version: 111.030.0609

    Nokia 700 phone:
    Release: Symbian Belle
    Software version: 111.010.1009

  2. #2
    Nokia Developer Expert
    Join Date
    Oct 2007
    Posts
    441

    Re: Does the qtmobility's gsensor have problem?

    Hi

    I don't see any problem with sensors. Accelerometer is here . Please try to build it and run on device. If you cannot, please do the following:

    1) reinstall fresh Qt SDK 1.2.1 --- i don't recommend other download source than developer.nokia.com
    2) make sure your device runs proper Qt environment. To do so, build Accelerometer project with Smart Installer. The latter will bring to the device all component dependencies if they are missing on the device (including QMobility update).

    i have checked Accelerometer app on N8-00 Belle

  3. #3
    Registered User
    Join Date
    Mar 2012
    Posts
    24

    Re: Does the qtmobility's gsensor have problem?

    Dear izinin

    This time I test on 700 and E7-00 phones.
    E7-00 can work.
    700 cannot work. (Already use the SmartInstall.)

    I find that the qt-mobility version is 1.2.0. (maybe I install sis in the QtSDK-1.1.3)

    I want to reinstall qt-mobility to 1.2.1.

    I use C:\QtSDK\Symbian\sis\Symbian_Anna\QtMobility\1.2.1\QtMobility-1.2.1-for-Anna.sis to install. (QtSDK-1.2.1)
    But failed. Phone show the "Unable to install. Qt,version 4.07(403) or newer is required."

    The following is the device information get from CODA:

    NOKIA 700 phone:
    Qt version:
    4.7.4
    OS version:
    Symbian^3, S60 5th Edition Feature Pack 3
    ROM version:
    111.010.1009 2011-08-19 RM-670 (c) Nokia
    Release:
    Symbian Belle
    CODA version:
    4.0.23
    Qt Mobility version:
    1.2.0
    Qt Quick components version:
    1.1.0
    QML Viewer version:
    Not installed
    Screen size:
    360x640

    NOKIA E7-00 phone:
    Qt version:
    4.7.4
    OS version:
    Symbian^3, S60 5th Edition Feature Pack 3
    ROM version:
    111.030.0609 2011-11-26 RM-626 (c) Nokia
    Release:
    Symbian Belle
    CODA version:
    4.0.23
    Qt Mobility version:
    1.2.1
    Qt Quick components version:
    1.1.0
    QML Viewer version:
    Not installed
    Screen size:
    360x640

    Jacky

  4. #4
    Nokia Developer Expert
    Join Date
    Oct 2007
    Posts
    441

    Re: Does the qtmobility's gsensor have problem?

    Hi Jacky

    Just to localize the problem: have you tried Accelerometer app ?

    Also i noticed in your first message mention about Home screen :
    Error message on phone: "Home screen: Feature not supported". (PS: this message seems happen in Janurary)
    What did you mean here?

  5. #5
    Registered User
    Join Date
    Mar 2012
    Posts
    24

    Re: Does the qtmobility's gsensor have problem?

    Dear izinin:

    Yes. I already test the Accelerometer app. But the result is the same.

    "Home screen: Feature not supported". ==> When I click QtAccelerometer APP in the menu, have a popup menu show that string.

    It seems that qtmobility 1.2 (in 700 phone) not work.
    And qtmobility 1.2.1 (in E7-00 and C7-00) work.

    I forgot that do I have change the qtmobility in 700 phone.
    Does qtmobility 1.2 come from original or not?

    Jacky
    Last edited by jacky.finalfantasy; 2012-06-27 at 10:51.

  6. #6
    Registered User
    Join Date
    Jul 2011
    Posts
    57

    Re: Does the qtmobility's gsensor have problem?

    Hi Jacki, I had the same problem with the 701 FW111.010.1009 , I rebuilt the app in Qt 4.7.3 instead of 4.7.4 and it passed QA with no problems.

  7. #7
    Nokia Developer Expert
    Join Date
    Oct 2007
    Posts
    441

    Re: Does the qtmobility's gsensor have problem?

    Hi Jacky

    As DrZ said , if you have not customized development environment by adding platform target manually and have up-to-date Qt SDK 1.2.1 , it works out-of-box. In that case you don't need to bother about certain QMobility version. Please see Qt dependency list below taken from Smart Installer
    Qt version 4.7.4 :
    1. QtWebkit 4.8.1
    2. QtMobility 1.2.1
    3. pips 1.7.5
    4. open_ssl 1.7.0
    5. stdcpp 1.7.0
    6. sqlite 0.50.0

    Now you can see Qt can be used as a bundle of component dependencies otherwise it does not work. In additional to the list there is QComponents 1.1.0 that depends on Qt

    This component dependency is maintained by Smart Installer for users' devices and for development environment you can take them from the SDK and install manually -- check SDK program group in Win main menu or they are available by path -- <QtSDK>\Symbian\sis\ in your SDK installation folder.

    To be sure your device runs correct environment. You can :
    1. factory reset the device.
    2. build your application with Smart Installer --- check "run option" in QCreator
    3. install your application on the device. During installation it will fetch correct environment on your device -- such way you will follow "user" case


    In case i misunderstood your trouble -- please ask me more questions

  8. #8
    Registered User
    Join Date
    Mar 2012
    Posts
    24

    Re: Does the qtmobility's gsensor have problem?

    Dear izinin:

    From the beginning:

    Before 2012/05/08, I use Qt4.7.3 to develop. (Qt_SDK_Win_offline_v1_2_en.exe)
    Accelerometer works well on E7-00, C7-00 and 700.

    At 2012/05/08, I use the maintain QT SDK to update componets to revision 8cd370e163.
    And I found Accelerometer cannot work on 700. But E7-00 and C7-00 can work well.

    Few days ago, I update to Qt4.7.4 to double check again. (QtSdk-offline-win-x86-v1_2_1.exe)
    And I found Accelerometer still cannot work on 700.

    From the above condition, if I want to publish the APP-with-gsensor, I will use Qt4.7.3 to build APP.

    PS1: As DrZ says, he seems also have the same problem. And recompile using QT4.7.3 instead of 4.7.4. And then 701 works.
    PS2: I already using SmartInstall to package SIS. But still failed on QT4.7.4.

    Jacky

  9. #9
    Nokia Developer Expert
    Join Date
    Oct 2007
    Posts
    441

    Re: Does the qtmobility's gsensor have problem?

    Hi Jacky

    I think there is some kind of miscommunication problem, could you point me link to the project you refer to?
    Please note that article is out-dated and should be somehow unpublished : http://www.developer.nokia.com/Commu...valuation_Tool

    And as for DrZ suggestion, i think recompiling using QT4.7.3 instead of 4.7.4 is not a solution because Qt dependency cannot be packaged according to publishing rules and Smart Installer will bring to device the latest Qt version

  10. #10
    Registered User
    Join Date
    Mar 2012
    Posts
    24

    Re: Does the qtmobility's gsensor have problem?

    Dear izinin:

    Sorry for reply lately.

    I test on two project example.
    one is get from qt-mobility-1.2. And the following is the path in my folder.
    ...\qt-mobility-qt-mobility-v1.2.0\qt-mobility-qt-mobility\examples\sensors\accel

    Another project source that I follow your post link.
    http://www.developer.nokia.com/Commu...bility_Project.

    I think that maybe only 700 and 701 (FW 111.010.1009) have this problem?

    Jacky

  11. #11
    Nokia Developer Expert
    Join Date
    Oct 2007
    Posts
    441

    Re: Does the qtmobility's gsensor have problem?

    Hi Jacky

    I just noticed your comment
    I use C:\QtSDK\Symbian\sis\Symbian_Anna\QtMobility\1.2.1\QtMobility-1.2.1-for-Anna.sis to install. (QtSDK-1.2.1)
    But failed. Phone show the "Unable to install. Qt,version 4.07(403) or newer is required."
    That is pretty simple situation -- installer complains because appropriate Qt version is not found on device. Go to Qt SDK installation , find sis directory and install Qt first and then QComponents.

    Please let me know if this app i have mailed you link before is working for you on N700

  12. #12
    Registered User
    Join Date
    Mar 2012
    Posts
    24

    Re: Does the qtmobility's gsensor have problem?

    Dear izinin:

    YES, after I install the Qt-4.7.403-for-Anna.sis and QtMobility-1.2.1-for-Anna.sis.
    And then QtAccelerometer APP can work.
    C:\QtSDK\Symbian\sis\Symbian_Anna\Qt\4.7.4\Qt-4.7.403-for-Anna.sis
    C:\QtSDK\Symbian\sis\Symbian_Anna\QtMobility\1.2.1\QtMobility-1.2.1-for-Anna.sis

    And then I install QtQuickComponents-1.1-for-Anna-Belle.sis, it also work.
    C:\QtSDK\Symbian\sis\Symbian_Anna\QtQuickComponents\1.1\QtQuickComponents-1.1-for-Anna-Belle.sis

    Thanks for your great support. ^_^

    Jacky

  13. #13
    Registered User
    Join Date
    Mar 2012
    Posts
    24

    Re: Does the qtmobility's gsensor have problem?

    Dear izinin:

    Can you give me a suggestion?
    If I want to build APP-with-gsensor, do I need use Qt4.7.3 or Qt4.7.4 to buld?
    Or both are not influence?

    I don't know why SmartInstaller not reinstall the Qt/QtMobility/QComponents.

    Jacky

  14. #14
    Nokia Developer Expert
    Join Date
    Oct 2007
    Posts
    441

    Re: Does the qtmobility's gsensor have problem?

    Hi Jacky

    I think for app sensor if you need QMobility 1.2.1 and correspondingly Qt 4.7.4, you shall use the latest Qt SDK, version 1.2.1 available for download on developer.nokia.com. With that SDK you can target your application for Anna and Belle platform versions. If you age going to publish you application and wish to distribute to all Qt 4.7.4 enabled phones, build your app against the Qt 4.7.4 Symbian Anna target

  15. #15
    Registered User
    Join Date
    Mar 2012
    Posts
    24

    Re: Does the qtmobility's gsensor have problem?

    Dear izinin:

    I got it. Thank you very much.

    Jacky

Similar Threads

  1. QtMobility's QBluetoothSocket connection issue.
    By RajeevSahu in forum [Archived] Qt Mobility Project
    Replies: 5
    Last Post: 2012-03-26, 12:08
  2. QtMobility's QBluetoothSocket::close() not working???
    By RajeevSahu in forum [Archived] Qt Mobility Project
    Replies: 9
    Last Post: 2011-11-18, 11:57
  3. QtMobility's class not recognized !
    By sami.mahjoub in forum [Archived] Qt SDKs and Tools
    Replies: 6
    Last Post: 2011-04-18, 10:21

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×