×

Discussion Board

Results 1 to 9 of 9
  1. #1
    Registered User
    Join Date
    Jul 2012
    Posts
    5

    Arabic links not working in my Nokia App

    Hello,

    I am the developer of Nokia application ID: 473096 , the Arabic links (when clicking on See original story) on the application not working and leads to 404 not found pages.

    Please any help or solution on that issue would be appreciated.

    Thanks

  2. #2
    Nokia Developer Expert
    Join Date
    Oct 2007
    Posts
    441

    Re: Arabic links not working in my Nokia App

    Hi

    If you are referring to your application by publishing id (473096) it is not accessible by ordinary user. So cannot check even understand your problem. You need to describe your problem clearer. Specify the application platform as well.

  3. #3
    Registered User
    Join Date
    Jul 2012
    Posts
    5

    Re: Arabic links not working in my Nokia App

    It is the the publish ID which is on my dashboard in nokiaappwizard.com
    When the normal user click on (see original story) on my Nokia phone app. , it redirects to 404 not found pages while these pages are accessible normally on the web.
    I have another app. which redirects to English links and works great, but this app. redirects to the Arabic part of my website and leads to Arabic links but the app. can't recognize these Arabic links and leads to 404 pages on my website after clicking on See original story.

  4. #4
    Nokia Developer Expert
    Join Date
    Oct 2007
    Posts
    441

    Re: Arabic links not working in my Nokia App

    Hello

    yes i got your problem. I need to learn more about nokiaappwizard.com perhaps there are some limitations. Does non-working url contains symbols that has to be URI encoded and perhaps Wizard does it incorrectly on does not encode at all? Could you share the broken link.

    Regards,
    Igor

  5. #5
    Registered User
    Join Date
    Jul 2012
    Posts
    5

    Re: Arabic links not working in my Nokia App

    The non-working links contains Arabic letters.
    Here is an example for one of the non-working links:
    http://www.smscafe.net/sms-portal/ar...A%D9%83%D9%89/

    BUT when the user click on (see original story) from the app. , it always leads to that link:
    http://www.smscafe.net/sms-portal/ar...1%01%01%01%01%
    which leads to 404 not found page.

    Please I am waiting for your help in that issue.
    Thanks.

  6. #6
    Nokia Developer Expert
    Join Date
    Oct 2007
    Posts
    441

    Re: Arabic links not working in my Nokia App

    Hi

    Try to instrument your feed with http://feedburner.google.com and provide the result link to the application wizard ---
    When you will go to feedburner and start the master you will be offered to select a feed that is available from your site and that will be instrumented with feedburner.

    the result link will look like http://feeds.feedburner.com/sms-portal-ar. Try to use that in http://nokiaappwizard.com. That should work.

    NOTE: Purpose of FeedBurner's services is to allow publishers who already have a feed to improve their understanding of and relationship with their audience. Even if you don't need FeedBurner services, I think it helps in your case because FeedBurner alters the original URL that you have trouble with.

    more info is here Essential FeedBurner questions

  7. #7
    Registered User
    Join Date
    Jul 2012
    Posts
    5

    Re: Arabic links not working in my Nokia App

    Hi,

    I have made that from 5 days, I have put http://feeds.feedburner.com/sms-portal-ar as my web content feed BUT the same problem still exist.

  8. #8
    Nokia Developer Expert
    Join Date
    Oct 2007
    Posts
    441

    Re: Arabic links not working in my Nokia App

    Hello

    That means the real application on device behaves differently than on web simulator. The only solution i can suggest is to have a url without national letters. That will definitely fix the problem. Is it possible to make different url for your content location by changing your server settings? If you own the server then there is no problem to do so i think.

    Regards,
    Igor

  9. #9
    Registered User
    Join Date
    Jul 2012
    Posts
    5

    Re: Arabic links not working in my Nokia App

    OK, thanks for your help.

Similar Threads

  1. Working rtsp links needed
    By marvik_34 in forum Symbian C++
    Replies: 0
    Last Post: 2008-08-01, 12:27
  2. Most of the Forum links are not working
    By PankajNeve in forum Feedback - Nokia Developer Services & Infrastructure
    Replies: 6
    Last Post: 2006-11-28, 00:47
  3. Links for S40 is NOT working
    By sasat in forum Mobile Java General
    Replies: 3
    Last Post: 2006-07-26, 02:20
  4. Some links are not working on the Nokia 9500
    By kotse0 in forum Mobile Web Site Development
    Replies: 1
    Last Post: 2005-02-07, 05:48
  5. Some links are not working on the Nokia 9500
    By kotse0 in forum Browsing and Mark-ups
    Replies: 1
    Last Post: 2005-02-07, 05:47

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •