Note that you should always use oldest platform SDK for the supported platform versions, meaning that if you plan to support 3rd ed FP1, you must compile the version for it with 3rd ed FP1 SDK or older, not FP2 SDK.