×

Discussion Board

Results 1 to 9 of 9

Hybrid View

  1. #1
    Registered User
    Join Date
    Jul 2012
    Posts
    5

    Problems with deploying to Nokia N9 with QtCreator

    I get following error message when I'm tying to follow hello world exaple for harmattan and qtcreator:
    Code:
    12:57:17: Running steps for project hello...
    12:57:17: Configuration unchanged, skipping qmake step.
    12:57:17: Starting: "/usr/bin/make" -w
    make: Entering directory `/home/tomin/etc/Ohjelmointi/Meego/hello-build-embedded-Qt_4_8_2_in_PATH__System__Release'
    Copying application data...
    make: Leaving directory `/home/tomin/etc/Ohjelmointi/Meego/hello-build-embedded-Qt_4_8_2_in_PATH__System__Release'
    12:57:17: The process "/usr/bin/make" exited normally.
    12:57:17: Uploading file '/home/tomin/etc/Ohjelmointi/Meego/hello-build-embedded-Qt_4_8_2_in_PATH__System__Release/hello'...
    mkdir: can't create directory '/opt/hello/': Permission denied
    12:57:17: Failed to upload file '/home/tomin/etc/Ohjelmointi/Meego/hello-build-embedded-Qt_4_8_2_in_PATH__System__Release/hello'.
    12:57:17: Deploy step failed.
    Error while building/deploying project hello (target: Embedded Linux)
    When executing step 'Upload files via SFTP'
    I get this when I click run. And I checked using ssh that indeed I can't create a dircetory using developer user.
    Code:
    $ ls -ld /opt
    drwxr-xr-x   40 root     root          4096 Jul 24 08:18 /opt
    $ mkdir /opt/hello
    mkdir: can't create directory '/opt/hello': Permission denied
    What should I do?

  2. #2
    Nokia Developer Expert
    Join Date
    Jun 2012
    Posts
    55

    Re: Problems with deploying to Nokia N9 with QtCreator

    Have you gone through http://doc.qt.nokia.com/qtcreator-2....ing-meego.html and set up the connection to the device?

    Br,
    Villep

  3. #3
    Registered User
    Join Date
    Jul 2012
    Posts
    5

    Re: Problems with deploying to Nokia N9 with QtCreator

    Well, the connection works and test seems to be fine.
    Code:
    Device test finished successfully.
    Now I checked better what the page says about project's settings and I don't think I have quite the same Run settings as they are not available. On that page it's set up to create package, but my computer is just set up to upload. Although the tutorial didn't say anything about that...

    The tutorial I'm following is this: http://harmattan-dev.nokia.com/docs/...th_Qt_SDK.html
    It seems to be for a bit older QtCreator as the first steps weren't exaclty the same, but I think I chose the right path.
    The version seems to be Qt Creator 2.5.0, Based on Qt 4.8.1 (64 bit) and it's run on Arch Linux. My N9 has 1.3 update installed if that matters.

    There is something weird in my installation as this program I built for the device is x86_64 application:
    Code:
    $ file /home/tomin/etc/Ohjelmointi/Meego/hello-build-embedded-Qt_4_8_2_in_PATH__System__Release/hello
    /home/tomin/etc/Ohjelmointi/Meego/hello-build-embedded-Qt_4_8_2_in_PATH__System__Release/hello: ELF 64-bit LSB executable, x86-64, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.32, BuildID[sha1]=0x8b523238ba551d3744d1c0509a0676e0706e086d, not stripped

  4. #4
    Nokia Developer Expert
    Join Date
    Jun 2012
    Posts
    55

    Re: Problems with deploying to Nokia N9 with QtCreator

    What username (the one in Linux Devices) are you using to connect to the device? Are you using Harmattan Target as the Qt version? Do you have the correct device selected in Run Settings -> Device configuration?

    Br,
    Villep

  5. #5
    Registered User
    Join Date
    Jul 2012
    Posts
    5

    Re: Problems with deploying to Nokia N9 with QtCreator

    I think so...
    https://dl.dropbox.com/u/4305182/Scr...6-13-56-34.png
    https://dl.dropbox.com/u/4305182/Scr...6-13-58-09.png
    except about that qt version, because I can't find such settings anywhere.
    https://dl.dropbox.com/u/4305182/Scr...6-14-00-10.png
    Should I have installed something in addition to qtcreator package?
    List of files in qtcreator: http://pastebin.com/RCkcMx8N

  6. #6
    Nokia Developer Expert
    Join Date
    Jun 2012
    Posts
    55

    Re: Problems with deploying to Nokia N9 with QtCreator

    Please check if you have Harmattan target installed if not, install it.

    Start Qt Creator, then Help -> Start Updater -> Package Manager.

    You should now get a list of installed components. Under Development tools you should see Harmattan. Under Harmattan you should have Harmattan Emulator, Qt Quick Components and Harmattan Target. If you do not have those installed (they should be checked if they are) then check atleast Harmattan Target and press next.

    Now Qt Creator should install the proper target and after that you can use that to create applications for Harmattan.

    Image to clarify http://imgur.com/xkHq5.

    Br,
    Villep

Similar Threads

  1. Segfault when deploying on N900 from QtCreator 2.0.1
    By Grinchman in forum [Archived] Qt SDKs and Tools
    Replies: 2
    Last Post: 2010-11-16, 08:01
  2. Problems deploying a dll on target
    By LavanyaSpm in forum Symbian
    Replies: 5
    Last Post: 2008-10-17, 10:54
  3. Problems with deploying jar file
    By Stalkin in forum Mobile Java General
    Replies: 3
    Last Post: 2008-04-14, 18:18
  4. Problems with deploying MIDlet to 6600 from NDS 2.0
    By johan_olsson76 in forum Mobile Java Tools & SDKs
    Replies: 2
    Last Post: 2003-11-12, 08:16
  5. Problems deploying midlets in Nokia9210.
    By Nokia_Archive in forum Mobile Java General
    Replies: 1
    Last Post: 2002-05-24, 14:25

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •