×

Discussion Board

Results 1 to 8 of 8
  1. #1
    Registered User
    Join Date
    Dec 2011
    Posts
    29

    Exclamation getting problem with pushregistry in j2me

    Hi,
    In my application am using push-registry feature (wake up midlet when notified with incoming message on perticular
    port). For this am using
    PushRegistry.registerConnection("sms://:" +PortNumber, "midletName", "*");

    application working fine ,but some times getting connection already registered exception . for this one everytime am unregister that connection and establishing again ,Still getting the same issue .can any one help me.

    Thanks in advance.
    Mamatha.S

  2. #2
    Nokia Developer Expert
    Join Date
    Oct 2007
    Posts
    441

    Re: getting problem with pushregistry in j2me

    Hi

    Please check if your connection is still valid after the exception has happened. If so you can just suppress exception --i.e. ignore it.

    Regards,
    izinin

  3. #3
    Nokia Developer Champion
    Join Date
    Feb 2009
    Location
    Noida, India
    Posts
    3,087

    Re: getting problem with pushregistry in j2me

    Another option is to move to static push registry - entry in JAD file for the same - PushRegistry.registerConnection("sms://:" +PortNumber, "midletName", "*");

    MIDlet-Push-1 : sms://:5012, CalPushHandlerMidlet, *
    thanks,
    ~Amitabh
    (Champion of the Month -Aug'13)
    Follow me on my blog for Innovative Mobile Apps

  4. #4
    Registered User
    Join Date
    Dec 2011
    Posts
    29

    Re: getting problem with pushregistry in j2me

    Thanks for your reply. But am to use static push registry connection i,e, configured with in the jad file. But when am trying to install the app it is
    showing Conflict application shoe items? message .Even am not able to install that app .
    Mamatha.S

  5. #5
    Nokia Developer Champion
    Join Date
    Feb 2009
    Location
    Noida, India
    Posts
    3,087

    Re: getting problem with pushregistry in j2me

    In case of conflict - try changing the port no#.
    thanks,
    ~Amitabh
    (Champion of the Month -Aug'13)
    Follow me on my blog for Innovative Mobile Apps

  6. #6
    Registered User
    Join Date
    Nov 2012
    Posts
    5

    Re: getting problem with pushregistry in j2me

    Hi Amitabh,

    Stuck for past 1 week figuring installation of my app with push registry.
    I am testing on X2-00. My jad looks as follows.

    Hello World app with push registry permission
    MIDlet-1: HelloMIDlet, , hello.HelloMIDlet
    MIDlet-Jar-Size: 2077
    MIDlet-Jar-URL: Push2.jar
    MIDlet-Name: Push2
    MIDlet-Push-1: sms://:16309,hello.HelloMIDlet,*
    MIDlet-Vendor: Vendor
    MIDlet-Version: 1.0
    MicroEdition-Configuration: CLDC-1.0
    MicroEdition-Profile: MIDP-2.0

    Did the following on X2-00
    1) Did a factory reset of phone, uninstalled all 3rd party applications, changed the port number from 16304 to 16309. Gives me the same "conflicting applications error"
    2) Changed existing application's port number to 16314 and midlet version to 2.2 still "conflicting applications error"
    3) Application Installs successfully only if I remove port number but retain javax.microedition.io.PushRegistry permission.
    5) Lastly the same jad and jar run successfullly on C3-01.

    Please let me know if you know What could be going wrong?

  7. #7
    Registered User
    Join Date
    Mar 2003
    Posts
    4,105
    Nothing. This is a bug in the Series 40 Platform MIDlet database. After some time, it gets corrupted. You do not know, how often I had that one. Completely resetting the device via its menu twice or three times in a row helped here. So far, never had to reset in via Nokia Phoenix software.

  8. #8
    Registered User
    Join Date
    Nov 2012
    Location
    Lahore, Pakista
    Posts
    58

    Re: getting problem with pushregistry in j2me

    I had the very same issue when using static push registry with Conflicting app, the solution people told me was to check if there is another copy of the same app placed somewhere in your mobile phone, I tried that but it didn't work, although it shows error if there is a duplicate app of same. I suggest to remove all apps you have in duplicate then restart your phone, after turning it on put your app and run. Because for the first time I did it, my app worked. Since then I didn't need to work more over it. Good Luck

Similar Threads

  1. J2ME PushRegistry.registerAlarm problem
    By kenichi24 in forum Mobile Java General
    Replies: 1
    Last Post: 2010-08-29, 06:19
  2. Replies: 1
    Last Post: 2009-06-24, 11:05
  3. Alaram in j2me using pushregistry
    By prakashforum in forum Mobile Java Networking & Messaging & Security
    Replies: 10
    Last Post: 2007-09-10, 08:19
  4. Replies: 1
    Last Post: 2007-06-26, 13:57
  5. Replies: 0
    Last Post: 2004-08-06, 13:35

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×