×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    Sep 2012
    Posts
    2

    Insert symbian belle and symbian 5th edition in qt as devices for compilation

    I'm sure it is very easy but I've looked for it for 2 hours and I've not found it:
    How can I add symbian 5th edition to devices for which I want to compile my application in qt 4.7.4!

    I created a new quick application (following this guide: http://www.developer.nokia.com/Devel...d/Step_2.xhtml )

    Then I tried to compile it and, using the simulator, I was able to see that it works fine (It shows "hello world")!
    Then I tried to compile it for my mobile phone (nokia c5-03 who has symbian 5th edition): I went to project, but in symbian device I find only "Qt 4.7.4 for Symbian Anna ..."!!! Where are the other versions of symbian (symbian belle and symbian 5th edition)?
    Is there a way to insert them?

    Thank you in advance! ;-)

  2. #2
    Nokia Developer Expert
    Join Date
    Oct 2007
    Posts
    441

    Re: Insert symbian belle and symbian 5th edition in qt as devices for compilation

    Hi

    Install older Qt SDK 1.1.2 and re-build you project for target Symbian^1 that is compatible with Symbian 5th
    in the SDK installation directory by path <QtSDK_463>\Symbian\sis\Symbian^1 you will find Qt 4.6.3 and Qt 4.7.3 installation component dependencies. To support QML (QtQuick applications) you need Qt 4.7.3

  3. #3
    Registered User
    Join Date
    Sep 2012
    Posts
    2

    Re: Insert symbian belle and symbian 5th edition in qt as devices for compilation

    But in the guide I read that with the last version of qt would be possible to compile for symbian 5th edition, too!
    Are there files to add to the installated qt to include this possibility?

  4. #4
    Nokia Developer Expert
    Join Date
    Oct 2007
    Posts
    441

    Re: Insert symbian belle and symbian 5th edition in qt as devices for compilation

    Hi

    with the last version of qt would be possible to compile for symbian 5th edition
    that is not correct . Instead ,on Qt SDK download page they recommend to use older version 1.1.2 for Symbian^1 (5th ed) target. I know the SDK customization with setting new build targets in most cases is unsuccessful .

Similar Threads

  1. Replies: 2
    Last Post: 2012-01-12, 13:33
  2. Symbian Belle compilation issue
    By chintandhruva in forum Symbian Tools & SDKs
    Replies: 7
    Last Post: 2011-11-22, 17:42
  3. Conditional compilation for S60 3rd edition devices.
    By keerthi.ck06 in forum Symbian
    Replies: 3
    Last Post: 2010-06-22, 14:06

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×