×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    Sep 2012
    Posts
    31

    Secured web api not working on series 40 devices

    Hi ,
    I have a Client installed on the device that consumes the web apis from a server app .
    It was a normal http url exposed in the beginning so it worked in all the devices without any issue.
    Now recently the server app is made to expose secure connection urls (https:// ) with a
    self generated certificate installed on the server . I tested the client with secure connection
    in series 60 , it downloads the certificate and allows be to interact with the server app.
    But the same app wen i tried to test it on the series 40 device it says "Untrusted application" and exits the
    application .Is there any way that i can make my application trusted other than signing the app . Please let me know if
    any one has work around for this issue.
    regards,
    venkatesh

  2. #2
    Nokia Developer Champion
    Join Date
    Feb 2009
    Location
    Noida, India
    Posts
    3,087

    Re: Secured web api not working on series 40 devices

    You have to get your app signed and also use some standard 3rd party certificate like verisign on the server side also (it will help on other platforms as well).
    thanks,
    ~Amitabh
    (Champion of the Month -Aug'13)
    Follow me on my blog for Innovative Mobile Apps

  3. #3
    Registered User
    Join Date
    Sep 2012
    Posts
    31

    Re: Secured web api not working on series 40 devices

    Quote Originally Posted by im2amit View Post
    You have to get your app signed and also use some standard 3rd party certificate like verisign on the server side also (it will help on other platforms as well).
    Hi Amit,
    Thanks for the reply
    Agreed that the application should be signed . But i found on other OS that there is a option of accepting a self generated certificate through the java code .
    Is there any such feasibility in Series 40 OS ? . I would appreciate your answer.
    Regards,
    Venkatesh

Similar Threads

  1. Problem with SIS(using online packager) for secured API's
    By sangramp@cybage.com in forum [Archived] Flash Lite on Nokia Devices
    Replies: 0
    Last Post: 2011-04-29, 11:38
  2. Replies: 1
    Last Post: 2010-08-28, 07:44
  3. Replies: 10
    Last Post: 2007-07-10, 06:59
  4. Replies: 0
    Last Post: 2004-05-07, 16:46
  5. Replies: 0
    Last Post: 2004-05-07, 16:46

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×