×

Discussion Board

Results 1 to 2 of 2

Hybrid View

  1. #1
    Registered User
    Join Date
    Jul 2011
    Posts
    57

    Belle Refresh broke QSystemNetworkInfo?

    Hi,

    I've got an app that uses the QSystemNetworkInfo networkName, I've had it break before when we went from Belle, to Belle FP1, and ltomuta advised it needed the WriteDeviceData capability added as it wasn't at the time documented, and it worked again.

    I've had a few email from people saying they upgraded to the Belle Refresh and it's stopped working. I've had day trying to figure out how to fix it, but I'm pretty stuck as it works on Belle + FP1. I hoping ltomuta's gunna pop up and point out something else thats changed.

    Code:
    CONFIG += mobility
    MOBILITY = systeminfo
    
    symbian:TARGET.CAPABILITY += ReadUserData
    symbian:TARGET.CAPABILITY += WriteDeviceData
    symbian:TARGET.CAPABILITY += ReadDeviceData
    symbian:TARGET.CAPABILITY += Location
    Code:
    SysInfo = new QSystemNetworkInfo(this);
    QSystemNetworkInfo::NetworkMode mode = sysInfo->currentMode();
    
    // Mode
    ui->ModeL->setNum(sysInfo->currentMode()); // 1 or 3 reported, GSM or WCDMA
    // Network Name
    ui->NetworkL1->setText(sysInfo->networkName(sysInfo->currentMode())); // No result
    ui->NetworkL2->setText(sysInfo->networkName(QSystemNetworkInfo::GsmMode)); // No result
    ui->NetworkL3->setText(sysInfo->networkName(QSystemNetworkInfo::WcdmaMode)); // No Result
    Cheers

  2. #2
    Registered User
    Join Date
    Jul 2011
    Posts
    57

    Re: Belle Refresh broke QSystemNetworkInfo?

    After a few days of trying, it looks like it's also gone via the CTelephony method.

    Edit: I can log into two networks, one works with CTelephony, the other doesn't.
    Last edited by DrZ; 2012-09-14 at 23:15.

Similar Threads

  1. Replies: 4
    Last Post: 2012-09-19, 02:08
  2. SSL Error / Belle Refresh
    By Benecore in forum [Archived] Qt Quick
    Replies: 2
    Last Post: 2012-09-17, 06:55
  3. Belle refresh with Qt 4.8 rolling out
    By vladestCh in forum Qt
    Replies: 5
    Last Post: 2012-09-04, 08:47
  4. QSystemNetworkInfo doesen't run on E51
    By cyphorious in forum [Archived] Qt Mobility Project
    Replies: 9
    Last Post: 2010-07-29, 15:28

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×