×

Discussion Board

Results 1 to 9 of 9
  1. #1
    Registered User
    Join Date
    Nov 2011
    Posts
    47

    Emulator crashes

    Hi, All.

    I've some issue with emulator. Emulator crashes on start. The last message in log:

    TSY: CMmCustomTsy::GetRequiredPlatSecCaps ipc=1000013
    TSY: CMmCustomTsy::GetRequiredPlatSecCaps policy=None
    TSY: CMmCustomTsy::ReqCompleted, aTsyReqHandle=86, aError=-5

    There is no any log string from my app. What can it be?
    Last edited by sani_ok; 2012-09-27 at 14:28.

  2. #2
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,166

    Re: Emulator crashes

    I would have a closer look into the epocwind.out to see whether there are other errors reported.

    Also if the emulator crashes when your applciation is executing, then do do some file logging to see what is executed just before the crash.

  3. #3
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,692

    Re: Emulator crashes

    When in doubt you can always try starting the emulator in itself, it has an entry in the Start menu or you can launch <Your SDK>\epoc32\release\winscw\udeb\epoc.exe directly.

  4. #4
    Registered User
    Join Date
    Nov 2011
    Posts
    47

    Re: Emulator crashes

    I don't see any logs from my application. Just system logs.

    If I lauch emulator from start menu, emulator runs normaly and application start as well.

    On other hand, I have another computer with the same code and enviropment, and everything is good on that machine.

  5. #5
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,166

    Re: Emulator crashes

    So then do check the epocwind.out to see what kind of errors are reported in there, they might give some ideas on where it fails.

  6. #6
    Registered User
    Join Date
    Nov 2011
    Posts
    47

    Emulator crashes

    Hi, All.

    Emulator crashes on start. It doesn't metter if I start it from Carbide or from Start menu.

    Last messages in log:
    22.130 Thread eiksrvs.exe::EikAppUiServerThread Panic KERN-EXEC 3
    22.140 Thread eiksrvs.exe::UikonWatchers Panic KERN-EXEC 3
    22.145 Thread eiksrvs.exe::ViewServerThread Panic KERN-EXEC 3
    22.145 FAULT: KERN 0x00000004 (4)

    How can I fix it?

  7. #7
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,166

    Re: Emulator crashes

    I would suggest checking the first indicated errors, those shown could be caused by something else that was reported in there..

  8. #8
    Registered User
    Join Date
    Jan 2005
    Location
    Italy
    Posts
    639

    Re: Emulator crashes

    Well... i just put
    Thread eiksrvs.exe::EikAppUiServerThread Panic KERN-EXEC 3
    into Google and I found:
    http://www.developer.nokia.com/Commu...ulator-Problem
    http://www.developer.nokia.com/Commu...r-on-Windows-7
    http://www.developer.nokia.com/Commu...-up-java-tools
    http://zlkmartin.wordpress.com/2010/...lator-problem/
    http://phoneinfo8.info/Symbian/Insta...l#.UG3duK5Ku2c
    they seem to be related to audio driver and/or mic
    you could give them a try

    hope it helps somehow
    pg

  9. #9
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,166

    Re: Emulator crashes

    Quote Originally Posted by pavarang View Post
    Well... i just put
    Thread eiksrvs.exe::EikAppUiServerThread Panic KERN-EXEC 3
    into Google and I found:
    http://www.developer.nokia.com/Commu...ulator-Problem
    http://www.developer.nokia.com/Commu...r-on-Windows-7
    http://www.developer.nokia.com/Commu...-up-java-tools
    http://zlkmartin.wordpress.com/2010/...lator-problem/
    http://phoneinfo8.info/Symbian/Insta...l#.UG3duK5Ku2c
    they seem to be related to audio driver and/or mic
    you could give them a try

    hope it helps somehow
    pg
    And the audio driver thing, should be showing there beforehand, so no point on checking the later panics, but actually it would be important to find the first one,..

Similar Threads

  1. S60 5th Edition Emulator Crashes
    By Yagiza in forum Symbian Tools & SDKs
    Replies: 26
    Last Post: 2010-08-07, 21:24
  2. S60 5th Emulator still crashes
    By mewers in forum Mobile Java Tools & SDKs
    Replies: 5
    Last Post: 2009-07-29, 11:26
  3. BT example crashes on emulator
    By saurbh_g in forum Symbian Networking & Messaging (Closed)
    Replies: 4
    Last Post: 2007-02-01, 19:33
  4. Series80 emulator crashes
    By qt_raip in forum Symbian Tools & SDKs
    Replies: 13
    Last Post: 2004-11-20, 19:30
  5. emulator crashes
    By StephanW in forum Symbian Tools & SDKs
    Replies: 1
    Last Post: 2004-04-20, 17:31

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×