×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    Mar 2009
    Posts
    65

    Nokia N8 Belle runonphone Linux

    Hello. I bought a Nokia N8 firmware 111.040.1511 and try to make the application work runonphone via USB.
    My operating system - Linux.
    In the settings USB i'm set "Nokia Suite", and connect phone to PC.
    As a result, the logs are:
    $ dmesg
    [ 2392.503149] usb 7-1: >new high-speed USB device number 16 using ehci_hcd
    [ 2392.629201] usbserial_generic 7-1:1.0: >The "generic" usb-serial driver is only for testing and one-off prototypes.
    [ 2392.629208] usbserial_generic 7-1:1.0: >Tell linux-usb@vger.kernel.org to add your device to a proper driver.
    [ 2392.629213] usbserial_generic 7-1:1.0: >generic converter detected
    [ 2392.629344] usb 7-1: >generic converter now attached to ttyUSB0
    [ 2393.200173] usb 7-1: >USB disconnect, device number 16
    [ 2393.200490] generic ttyUSB0: >generic converter now disconnected from ttyUSB0
    [ 2393.200512] usbserial_generic 7-1:1.0: >device disconnected
    After modprobe usbserial vendor=0x0421 product=0x0302, nothing changes.
    How to fix?

  2. #2
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Budapest, Hungary
    Posts
    28,570

    Re: Nokia N8 Belle runonphone Linux

    While I have absolutely no experience with these tools, I found this description: http://harmattan-dev.nokia.com/docs/...ian-linux.html
    Are you following that one? It may or may not matter to have TRK running already when you are trying to connect.
    Also, with Belle it may happen that TRK is not any more, but you have CODA instead, and a possible requirement for some manual changes: http://qt-project.org/forums/viewthread/14427
    I do not use Linux right now either, however I do remember that there are dozens of distributions and myriads of different kernel versions. Naming yours may help in getting suggestions.

  3. #3
    Registered User
    Join Date
    Mar 2009
    Posts
    65

    Re: Nokia N8 Belle runonphone Linux

    If you have time to press connect to Coda during the first seconds after the USB connection to the PC, the connection is, but immediately disappears. The logs appear that I have laid outю
    Linux distributions name, which i'm use is ArchLinux, but i tried on Ubuntu 10.04. The same result.

Similar Threads

  1. Nokia Belle to Windows 7.5
    By pandiarajank in forum General Development Questions
    Replies: 2
    Last Post: 2012-09-07, 09:03
  2. Nokia N8 Belle FP1
    By frasene in forum General Development Questions
    Replies: 2
    Last Post: 2012-07-30, 13:07
  3. Nokia Belle widget API
    By ionionica in forum Symbian Tools & SDKs
    Replies: 6
    Last Post: 2012-05-10, 16:18
  4. Nokia Belle Development
    By ronie.amata in forum Mobile Java Tools & SDKs
    Replies: 3
    Last Post: 2012-04-02, 15:33

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •