×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    Oct 2012
    Posts
    2

    First app issues on Belle FP1/2

    Hi,
    this is my first post here and also my first qt app. This app is a simple qt webkit experiment that loads a local html page (that contains ajax calls to remote urls). No problem in the qt creator simulator, but when I launch it on the phone (nokia 700) it only shows the "waiting pointer" and then a black screen is shown (sometimes it's trasparent as I can see icons on background).
    In Belle FP1 I discovered that after installing qt-quick-components 1.1 on the phone the app worked beatifully. But after the FP2 update if I install that library the new camera app stop working (black screen) and I have to deep reset the phone to get it back! So I suppose there is a kind of conflict and installing qt-quick is not the right solution.

    Anywhere i post a bit of code and hope someone can help me...

    main qml:

    Code:
    import QtQuick 1.1
    import com.nokia.symbian 1.1
    import QtWebKit 1.0
    
    Rectangle {
    
        Flickable {
            id: flickable
            width: parent.width
            height:  parent.height
            contentWidth: webView.width
            contentHeight: webView.height
            interactive: true
            clip: true
    
            WebView {
                id: webView
                url:  "qrc:///html/test.html"
                preferredWidth: flickable.width
                preferredHeight: flickable.height
                onAlert: console.log("WebView onAlert: " + message)
                settings.localContentCanAccessRemoteUrls: true
                javaScriptWindowObjects: QtObject {
                     WebView.windowObjectName: "qml"
                     function closeApp() {
                         //console.log("This call is in QML!");
                         //QmlApplicationViewer.hide();
                         Qt.quit();
                     }
                 }
    
            }
    
        }
    
    }
    main.cpp:

    Code:
    #include <QtGui/QApplication>
    #include "qmlapplicationviewer.h"
    #include <QtNetwork/QNetworkProxyFactory>  //aggiunta da me
    
    Q_DECL_EXPORT int main(int argc, char *argv[])
    {
        QScopedPointer<QApplication> app(createApplication(argc, argv));
    
        QNetworkProxyFactory::setUseSystemConfiguration ( true) ; //aggiunta da me
    
        QmlApplicationViewer viewer;
        //viewer.setProperty("orientationMethod", 1);
        viewer.setMainQmlFile(QLatin1String("qml/test/main.qml"));
        viewer.showExpanded();
    
        return app->exec();
    }

  2. #2
    Registered User
    Join Date
    Jul 2012
    Posts
    5

    Re: First app issues on Belle FP1/2

    i have similar problem as well, and i developed a qt qml app, and it run well on other devices, when it runs on 808, it shall 'waiting' sign, and takes 5-6 seconds, still black screen.

    do you have further method now?

  3. #3
    Registered User
    Join Date
    Oct 2012
    Posts
    2

    Re: First app issues on Belle FP1/2

    Still no solution for me...

Similar Threads

  1. when the belle fp2 will be available?
    By dato_k in forum News and Announcements
    Replies: 8
    Last Post: 2012-09-08, 05:20
  2. Belle for e5
    By linuxlover in forum General Development Questions
    Replies: 2
    Last Post: 2012-08-09, 17:36
  3. Hello World of S60 GUI APP on Belle 0.6 SDK
    By rocjohn in forum Symbian Tools & SDKs
    Replies: 15
    Last Post: 2012-04-01, 12:19
  4. QA failing again & again for application icon and UID issues. Please solve my issues.
    By GTO_India in forum [Archived] Publish to Nokia Store – General Discussion
    Replies: 15
    Last Post: 2011-12-10, 14:11

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •