×

Discussion Board

Results 1 to 1 of 1
  1. #1
    Registered User
    Join Date
    Jan 2011
    Posts
    17

    Exclamation Buttons in LCD forms start on a new line in S40 SDK 2

    My app has navigation buttons on various view forms - e.g. Next, Previous, Detail, etc. The first button uses Item.LAYOUT_NEWLINE_BEFORE and the following buttons use Item.LAYOUT_DEFAULT (I have also tried Item.LAYOUT_2 but this changed nothing).

    On S40 E3 & E6 and S60 these are displayed horizontally in a single row (with wrapping if necessary) at the end of the form.

    On S40 SDK 2, these are displayed vertically - i.e. each button starts an new line / row. It's what I would expect to see if all buttons used Item.LAYOUT_NEWLINE_BEFORE.

    The same behaviour is found on emulators and devices. I think this may be a platform bug and I can't see a way around it
    Last edited by javadude; 2012-10-23 at 10:00. Reason: Corrected emulator edition

Similar Threads

  1. Start Application (JAD) and Emulator from Command Line
    By cosmos24 in forum Mobile Java General
    Replies: 4
    Last Post: 2011-05-21, 17:15
  2. Can't start a new line using CAknTextQueryDialog
    By etarip in forum Symbian User Interface
    Replies: 2
    Last Post: 2008-12-25, 14:57
  3. Replies: 1
    Last Post: 2006-10-21, 05:32
  4. Is it possible to start the application immidiately from command line?
    By calleandersson in forum Mobile Java Tools & SDKs
    Replies: 3
    Last Post: 2006-03-02, 20:58
  5. Start the own app from command line in emulator
    By vsuontam in forum Symbian Tools & SDKs
    Replies: 0
    Last Post: 2005-01-11, 10:56

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •