×

Discussion Board

Page 1 of 2 12 LastLast
Results 1 to 15 of 16
  1. #1
    Registered User
    Join Date
    Dec 2009
    Posts
    339

    What is platform suitable for APSServer2?

    What is S60 version suitable for the APSServer uploaded on this page? As stated in a wiki known issue that S60 3rd Edition MR and S60 3rd Edition FP1 devices require different versions of the APS server binaries.Could anyone please confirm the S60 version(MR or FP1) of the APSServer2 ? thanks

  2. #2
    Nokia Developer Champion
    Join Date
    Jun 2008
    Location
    Noida,India
    Posts
    3,957

    Re: What is platform suitable for APSServer2?

    Try downloading the plugin from here http://www.developer.nokia.com/Commu...DK_API_Plug-in. Its APS V2.43 only which runs on MR/FP1 or above devices.

  3. #3
    Registered User
    Join Date
    Dec 2009
    Posts
    339

    Re: What is platform suitable for APSServer2?

    Quote Originally Posted by vineet.jain View Post
    Try downloading the plugin from here http://www.developer.nokia.com/Commu...DK_API_Plug-in. Its APS V2.43 only which runs on MR/FP1 or above devices.
    Thanks vineet for your reply. As I see from hhe SDK API plugin download page contains two different sections for MR and FP1 platfrom. And in a wiki known issue it is stated that MR and FP1 requires two different binaries for each platform. But APSServer for each platform links to the same download page. The latest version of the Audio Proxy Server SIS file download page does not contain any information about S60 platform. Does it mean that the known issue problem is solved with the new APSServer? thanks

  4. #4
    Nokia Developer Champion
    Join Date
    Jun 2008
    Location
    Noida,India
    Posts
    3,957

    Re: What is platform suitable for APSServer2?

    Yes, i too came across the issue of binary compatibility of APS for different platforms. So a thumb rule is that if you download the MR version of SDK plugin then install the contained APS supporting sis file(APSServer.sisx) into an MR device only.Likewise is the case for FP1 as well. Installing APS supporting sis files into cross platform devices raises an error.

  5. #5
    Registered User
    Join Date
    Dec 2009
    Posts
    339

    Re: What is platform suitable for APSServer2?

    APSServer for MR devices contained in S60_3rd_SDK_MR_API_Plug-In_Pack_v5_43 downloaded directory and APSServer for FP1 devices contained in S60_3rd_Ed_SDK_FP1_API_Plug-In_Pack_v2_5 is showing error "Certificate Expired" while installing. Is there any new APSServer for respective MR and FP1 devices? thanks

  6. #6
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Budapest, Hungary
    Posts
    28,572

    Re: What is platform suitable for APSServer2?

    Well, you have an archived(!) known issue from 2007 and the big plug-in packages containing .sis files which can not be installed any more. The pages talk about APS version 2.1 and 2.3.
    On the other hand you have a separate download, version 2.40.3, originating from January, 2012, on a page explicitly saying that it can be installed until 2016.
    Do you see any obstacles which could prevent you from installing this package to any device and see if it works?

  7. #7
    Registered User
    Join Date
    May 2008
    Posts
    29

    APS-2.4.3 Installation Error(Expired Certificate) in N73 and E61

    Hello,

    I am using Symbian Audio Proxy Server (APS) Version. 2.4.3 in my VoIP application. Recently I found an problem it show "Expired Certificate" error at installation time. If I change my Mobile time to back 1/2 month then it works fine.

    But my customer did not do this at installation time. How can I resolve this issue.

    Please help me if anyone have experienced this issue.

    Thanks,
    Salah Uddin Ahmed

  8. #8
    Nokia Developer Expert
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,143

    Re: APS-2.4.3 Installation Error(Expired Certificate) in N73 and E61

    Basically you would need to repack the application and see that all certificates are valid, including the ones used for embedded sis files.

  9. #9
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Budapest, Hungary
    Posts
    28,572

    Re: APS-2.4.3 Installation Error(Expired Certificate) in N73 and E61

    Are you using some package from the plug-in pack, or the separate build provided as Apsserver2 (under "Download" on http://www.developer.nokia.com/Commu...o_Proxy_Server)? That one is said to be valid until 2016.

  10. #10
    Registered User
    Join Date
    May 2008
    Posts
    29

    Re: APS-2.4.3 Installation Error(Expired Certificate) in N73 and E61

    Thanks for your quick reply...

    Actually I using APS with my VoIP application. I pack APS sis file with my application sis file and then sign this with my developer certificates. Actually I have been using this for last 2 years. But since last 2-3 days I could not install this in my N73 or E61. It just show "required application access not granted" when I using it as embedded with my sis file.

    Here I also mention that, I have already signed my application through symbiansigned.com but now that application also show this error message on those devices.

    my application Link: http://64.5.32.228/122

    Thanks,
    Salah Uddin Ahmed

  11. #11
    Registered User
    Join Date
    May 2008
    Posts
    29

    Re: APS-2.4.3 Installation Error(Expired Certificate) in N73 and E61

    @wizard_hu Thanks for reply...

    I am using this from plug-in-pack.

    Yes your given link is working... But using this APS in my application Loudspeaker not working in E61 and N73.

    I also test this on E71 and E63 its working fine...

    Is there any issue... Do you have any idea...

    E63: Symbian OS 9.2, Series 60 v3.1 UI
    E61: Symbian OS 9.1, Series 60 UI
    E71: Symbian OS 9.2, Series 60 v3.1 UI
    N73: Symbian OS 9.1, S60 3rd edition

    Thanks,
    Salah Uddin Ahmed

  12. #12
    Registered User
    Join Date
    Dec 2009
    Posts
    339

    Re: What is platform suitable for APSServer2?

    Quote Originally Posted by wizard_hu_ View Post
    Well, you have an archived(!) known issue from 2007 and the big plug-in packages containing .sis files which can not be installed any more. The pages talk about APS version 2.1 and 2.3.
    On the other hand you have a separate download, version 2.40.3, originating from January, 2012, on a page explicitly saying that it can be installed until 2016.
    Do you see any obstacles which could prevent you from installing this package to any device and see if it works?
    Using the APSServer(from separate download) audio can not be routed to loudspeaker in S60 3rd Edition MR devices(in FP1 and FP2 devices it is working ). But using the APSServer that was found from API plugin of MR devices, audio can be routed to loudspeaker in S60 3rd edition MR devices.What might be the reason audio can not be play in loudspeaker in MR devices using that apsserver? thanks

  13. #13
    Registered User
    Join Date
    Feb 2008
    Posts
    209

    Re: What is platform suitable for APSServer2?

    Hi , i am using latest apsserver2 for s60 3.0MR and it is valid till 2016, but it is giving unable to install, i am trying on Nokia N73 device.

    pls help..

  14. #14
    Nokia Developer Expert
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,143

    Re: apsserver2 for s60 3.0MR and it is valid till 2016, but it is giving unable to in

    Are you sure its the sis file you think that gives the error ?

    Basically this error comes most likely from trying to overwrite an existing file in the device which was not installed with the same sis file originally. Also with some old MR devices, this error comes if the sis files tries to install file to a private folder which is different than the one specified in the pkg file, even if it is correct and is for one of the executable installed with the file.

  15. #15
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Budapest, Hungary
    Posts
    28,572

    Re: apsserver2 for s60 3.0MR and it is valid till 2016, but it is giving unable to in

    Hi, I have merged the 3 discussions, perhaps it makes sense.
    As far as I understand now, APSServer2, in the separate package is the only one which can be installed without altering the date on the device. However it has problems with routing on S60 3rd edition initial release devices.

Similar Threads

  1. Replies: 9
    Last Post: 2011-04-20, 08:13
  2. Replies: 4
    Last Post: 2010-02-25, 16:35
  3. Detecting ApsServer2.sisx
    By ronald29 in forum Symbian
    Replies: 7
    Last Post: 2008-02-28, 11:27
  4. what is sdk and platform suitable....
    By azean in forum Symbian
    Replies: 3
    Last Post: 2006-12-04, 08:37
  5. what is sdk and platform suitable....
    By azean in forum Tools and SDK Feedback (Closed)
    Replies: 3
    Last Post: 2006-12-04, 08:37

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •