×

Discussion Board

Results 1 to 6 of 6
  1. #1
    Registered User
    Join Date
    Jul 2012
    Location
    Brno, Czech Republic
    Posts
    16

    How do I develop for S60 5th ed.?

    Hi, I'd like to make my Qt-based application available for S60 5th edition-based phones. I realized I have S60 5th edition toolchain installed on my PC as a part of Qt SDK:


    However I can only add Desktop and Harmattan target in Projects and the only build configuration offered for Symbian target is "Qt 4.7.4 for Symbian Anna".

    So can I build the app for S60 5th ed. somehow or do I have to install something more?

  2. #2
    Nokia Developer Champion
    Join Date
    Mar 2003
    Location
    Finland
    Posts
    9,545

    Re: How do I develop for S60 5th ed.?

    You need an older Qt SDK (v4.6.something, I recall, was the last one that supported S60 5th Ed.), if you want to do it with Qt.

  3. #3
    Registered User
    Join Date
    Jul 2012
    Location
    Brno, Czech Republic
    Posts
    16

    Re: How do I develop for S60 5th ed.?

    OK, but why do I have the "S60 5th ed." toolchain listed in Maintenance tool if I can't do anything with that? What's the purpose of the toolchain?
    In addition, I also found some device .sis files for S60 5th ed. on my hard drive: Performance Monitor, Energy Profiler, Qt Mobility etc.
    Is it only included to eat hard drive space??

  4. #4
    Super Contributor
    Join Date
    Jan 2009
    Location
    Melbourne, Australia
    Posts
    2,578

    Re: How do I develop for S60 5th ed.?

    Quote Originally Posted by ondrej_andrej View Post
    Is it only included to eat hard drive space??
    Yes (probably).

    The first version that broke backwards compatibility only did so in that you could not longer do on-target debugging with the SDK. So at that point the SDK was still potentially useful and included these tools. I suspect that the breaks are now much more profound (and in any case on target debugging is essential) and these versions of the tools have simply never been cleaned up.

  5. #5
    Registered User
    Join Date
    May 2009
    Location
    Greece
    Posts
    191

    Re: How do I develop for S60 5th ed.?

    If you want to target Symbian 5th devices just download Qt SDK 1.1,
    place it at a different destination folder and have it along with Qt SDK 1.2 .

    The Qt SDK 1.1 was the last official release that supported Symbian 5th and older device. Just bare in mind, when Qt Creator (included in 1.1 version) starts, don't press the update which will lead you once again at 1.2 version.

    (I wont bother making a comment on why the Symbian toolchains exist where at the maintenance tool)

  6. #6
    Registered User
    Join Date
    Jul 2012
    Location
    Brno, Czech Republic
    Posts
    16

    Re: How do I develop for S60 5th ed.?

    Thanks, I was looking exactly for this information.

Similar Threads

  1. How to Develop 4.6.3 Qt app
    By senu188 in forum [Archived] Qt SDKs and Tools
    Replies: 1
    Last Post: 2011-06-07, 10:32
  2. Replies: 6
    Last Post: 2011-02-11, 14:18
  3. help me to develop
    By dheeraj.jain4u in forum Mobile Java General
    Replies: 2
    Last Post: 2010-01-25, 17:11
  4. Which one to develop for?
    By kevinwoodruff in forum Mobile Commerce
    Replies: 1
    Last Post: 2002-12-19, 09:02
  5. t9 develop
    By erio_prihastono in forum Symbian C++
    Replies: 1
    Last Post: 2002-09-10, 07:34

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •