×

Discussion Board

Results 1 to 9 of 9

Hybrid View

  1. #1
    Registered User
    Join Date
    Sep 2012
    Posts
    2

    Angry URL doesnt work

    the url http://demo.places.nlp.nokia.com/pla...cover/explore? doesnt work. What is happening?

  2. #2
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Budapest, Hungary
    Posts
    28,568

    Re: URL doesnt work

    It is reachable for me. What do you experience? HTTP 404?

  3. #3
    Registered User
    Join Date
    Sep 2012
    Posts
    2

    Re: URL doesnt work

    Is very unstable. Anytime OK and anytime Http 404! My connection is good and works well with another URLs.

  4. #4
    Super Contributor
    Join Date
    Jan 2009
    Location
    Melbourne, Australia
    Posts
    2,578

    Re: URL doesnt work

    FYI, Moved thread to correct forum "Places API"

  5. #5
    Registered User
    Join Date
    Nov 2012
    Posts
    1

    Places REST API returning 404 error

    Hello,

    I have tried accessing the Places REST API endpoints in a lot of the ways found in the documentation both with demo keys and real API keys. I always get a 404 error on all requests like:

    http://demo.places.nlp.nokia.com/discover/search?...
    http://demo.places.nlp.nokia.com/discover/explore?...

    See test for JSONP request: http://jsbin.com/igutev/2

    Any pointers would be helpful! Thanks!

  6. #6
    Registered User
    Join Date
    Nov 2012
    Posts
    1

    Re: Places REST API returning 404 error

    Just came here to say I'm seeing the same thing. So, if there's some Nokia representatives monitoring the forum, please be aware that your demo.places.nlp.nokia.com test site doesn't seem to be responding.

  7. #7
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Budapest, Hungary
    Posts
    28,568

    Re: Places REST API returning 404 error

    Now it does not work for me either.

  8. #8
    Super Contributor
    Join Date
    Jan 2009
    Location
    Melbourne, Australia
    Posts
    2,578

    Re: Places REST API returning 404 error

    Quote Originally Posted by goishin View Post
    Just came here to say I'm seeing the same thing. So, if there's some Nokia representatives monitoring the forum, please be aware that your demo.places.nlp.nokia.com test site doesn't seem to be responding.
    I'll forward to the right person.

  9. #9
    Nokia Developer Expert
    Join Date
    Apr 2012
    Posts
    4

    Re: URL doesnt work

    This thread seems to mix up two different topics:

    Initially it was about unstable behavior of our service. Neither our service monitoring nor our log files inidicate any instability of the demo-servers. We are still investigating, but so far could not find anything.

    The second topic relates to bugs in the published documentation, which misses a critical URL path segment: Every Places API call URL starts with a path segment "/places/v1". So instead of

    http://demo.places.nlp.nokia.com/discover/explore...

    you must use: http://demo.places.nlp.nokia.com/pla...scover/explore...

    (and similarly http://demo.places.nlp.nokia.com/pla...iscover/search )

    We've reached out to the documentation team to get those bugs fixed asap.

    Until then, the simplest way to get started with the Places API is to use the playground

    http://demo.places.nlp.nokia.com/places

    in a regular browser.

    There you can simply choose one of the API features and then copy/paste the URL from your browser into your app.

    Hope that helps,
    Andreas
    Last edited by hamishwillee; 2012-11-29 at 00:22.
    Andreas Schmidt
    Nokia Places API

Similar Threads

  1. Carbide returning SBS error
    By sri.appana in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 2
    Last Post: 2010-04-10, 13:47
  2. Replies: 0
    Last Post: 2009-02-02, 16:48
  3. SIP SendSubscribeL returning -11 error
    By satya3050 in forum Symbian Networking & Messaging (Closed)
    Replies: 2
    Last Post: 2006-12-15, 09:36
  4. Socket connection not returning error code?
    By jestyjames in forum Symbian Networking & Messaging (Closed)
    Replies: 12
    Last Post: 2005-05-16, 10:30
  5. Socket connection not returning error code!
    By jestyjames in forum Symbian
    Replies: 1
    Last Post: 2005-02-27, 11:15

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •