I'm implementing nokia inapp purchase for asha 311. My app uses items that are "Bundled in the app" and can be unlocked on purchase. I tried running my app with a product id "865729" but I got a "-8(INVALID_PRODUCT_ID)" when I used emulator "Nokia SDK 2.0" and "SDK Local Simulation(No interaction outside SDK)". But when I used "Test with Nokia Publish Server(Using network connection)" I got a "-35(GENERAL_HTTP_ERROR)" for the same product id i.e. "865729". And I get the same status code when I run the application on the device(nokia asha 311). Also my IAP_VARIANTID.TXT contains 000000(with no white space/new lines) and TEST_MODE.TXT contains:
[testserver]
testMode=purchase

So I tried checking with another product id which is used in "LWUIT Tourist Attractions"(http://projects.developer.nokia.com/...istAttractions) i.e.,
766918 in my app just to check. I get "-35(GENERAL_HTTP_ERROR)" in my emulator when I used "Test with Nokia Publish Server(Using network connection)" and a success i.e., "1" in case I use "SDK Local Simulation(No interaction outside SDK)". Also when running on the device I get a -35.

Next I tried running the "LWUIT Tourist Attractions" on my device but I get a "Loading new guides failed. There was a problem with Nokia Services. Please try...". I also tried running both apps on RDA at different times during the day. At one time I was able to make a successful purchase in both apps. But, nonetheless it failed in next attempt and I get a "Unable to complete the purchase. Try again later" error for both "LWUIT Tourist Attractions" and my app.

While debugging more I also saw this that I got a "Error 500: Server Error" when my app tried accessing "https://payment.ovi.com/operest/1.1/purchase?method=GET" or even when "LWUIT Tourist Attractions" accessed this.

Don't know what is causing this issue. Any help will be greatly appreciated.