×

Discussion Board

Results 1 to 15 of 15
  1. #1
    Registered User
    Join Date
    May 2013
    Posts
    8

    Cannot deploy Phoneapp1 to my lumia 920

    Hi, using vs express 2012 for wp8, when i try to Deploy Phoneapp1
    I get ....
    Error 1 The system cannot find the file specified. (Exception from HRESULT: 0x80070002)
    Please rebuild the solution and try again.

    I rebuild and there are no error messages but when deploy, I get 0x80070002)

    My dell i3 64b windows 8 pro computer is usb attached to my lumia 920 which is unlocked and I have just purchased developers licence.

    Thank-you
    Wayne

  2. #2
    Registered User
    Join Date
    Jan 2013
    Posts
    34

    Re: Cannot deploy Phoneapp1 to my lumia 920

    Does it deploy fine to the emulator?

    Do you have the phone developer unlocked?

  3. #3
    Registered User
    Join Date
    May 2013
    Posts
    8

    Re: Cannot deploy Phoneapp1 to my lumia 920

    Hi paulo, no, my visual studio express for wp8 toolbox shows "start" and I cannot deploy phoneapp1 to the emulator or deploy to my lumia 920

    When try to deploy phoneapp1 to lumia, the IDE says... the system cannot find the file specified. (Exception from HRESULT: 0x80070002) it does not show name of the file.

    Yes the lumia is unlocked using windows phone developer registration.

  4. #4
    Nokia Developer Moderator
    Join Date
    Feb 2011
    Location
    Portugal
    Posts
    946

    Re: Cannot deploy Phoneapp1 to my lumia 920

    This can be a number of things.

    I had some strange problems deploying apps to the phone ion the past that didnt happen when publishing to the emulator.

    So the first thing to check if if you are using debug mode and release mode. Publish in the same mode to the phone and emulator to make sure you have a consistent deploy.

    Also check for files included in your project. See if you have everything is included on the project. Sometimes you may get an error publishing to the phone and not to the emulator when a file is missing.

    Make also sure that you have all capabilities that your app requires selected on the project properties.

    The error message you are seeing is a generic VS.NET error, its not directly related to the phone.

    Also it would help if you could past here the Output Window contents.

  5. #5
    Registered User
    Join Date
    May 2013
    Posts
    8

    Re: Cannot deploy Phoneapp1 to my lumia 920

    Sure thanks Joao, oh how do I attach the jpg, I only see icon for insert image which wants a URL, can it be c:\the jpg name ? in the url field

    anyway until I can upload my pics to you, this is my Output Window contents
    when I try to Deploy Phoneapp1 and when I deploy solution, error is the same


    Error 1 The system cannot find the file specified. (Exception from HRESULT: 0x80070002)
    Please rebuild the solution and try again. 0 0
    Last edited by wlab; 2013-05-22 at 19:00. Reason: more info

  6. #6
    Nokia Developer Moderator
    Join Date
    Feb 2011
    Location
    Portugal
    Posts
    946

    Re: Cannot deploy Phoneapp1 to my lumia 920

    Quote Originally Posted by wlab View Post
    Sure thanks Joao, oh how do I attach the jpg, I only see icon for insert image which wants a URL, can it be c:\the jpg name ? in the url field

    anyway until I can upload my pics to you, this is my Output Window contents
    when I try to Deploy Phoneapp1 and when I deploy solution, error is the same


    Error 1 The system cannot find the file specified. (Exception from HRESULT: 0x80070002)
    Please rebuild the solution and try again. 0 0
    On the Insert Image dialog you should have also an option "From computer". Can you find it?

    Anyway, is your project confidential? If not if you want send it to me at lusocoder @ hotmail.com and I will test the deploy to my L920.

  7. #7
    Registered User
    Join Date
    May 2013
    Posts
    8

    Re: Cannot deploy Phoneapp1 to my lumia 920

    I have only icon Insert image and
    Add an Image from Url
    Allowed Filetypes: jpg, jpeg, png, gif

    no from computer option.
    I will send .jpg to your email.

    the app is just phoneapp1 that is the learning app when you 1st use ws express for windows phone 8, it should be on your opening ide page.

  8. #8
    Regular Contributor
    Join Date
    Jan 2009
    Location
    India
    Posts
    138

    Re: Cannot deploy Phoneapp1 to my lumia 920

    Hi,

    AS far as I know, this issue is comes when you are try to load any file from the device or solution. so you make sure that the following thing that you are using in your application.

    1) Are you trying to load any image or xml file in your application.

    If Yes: then path must start with "ms-appx:///"

    See the below example

    Uri pathUri = new Uri("ms-appx:///wmdev.png"));

    You can try it, this is based on my assumption only.

    Hope it helps
    Last edited by pavan.pareta; 2013-05-24 at 06:43.
    Pavan Pareta
    Sr. Software Engineer
    http://windows-mobile-dev.blogspot.com

  9. #9
    Nokia Developer Moderator
    Join Date
    Oct 2006
    Location
    Finland
    Posts
    4,541

    Re: Cannot deploy Phoneapp1 to my lumia 920

    Quote Originally Posted by wlab View Post
    Sure thanks Joao, oh how do I attach the jpg, I only see icon for insert image which wants a URL, can it be c:\the jpg name ? in the url field
    If I understood your quoted issue correctly, You will not be able to attach the image till you have become a relatively regular poster (earlier it used to be 50 but I think now its 100 posts). This has been put in place to protect against spamming.

  10. #10
    Registered User
    Join Date
    May 2013
    Posts
    8

    Re: Cannot deploy Phoneapp1 to my lumia 920

    Pavan, I will definitely check this.
    btw I finally gave up and ran Reset of my computer. Re-installed ide and life is good. Wish that I could have solved the problem without doing that.

  11. #11
    Registered User
    Join Date
    May 2013
    Posts
    8

    Re: Cannot deploy Phoneapp1 to my lumia 920

    Hello Neil, understand, wish this was displayed somewhere that is easy to see so that you and I did not have to spend time on it.
    btw what about new developers looking for answers, kind of limits their ability to explain in wordy text until get to 100 posts. Perhaps a way by the moderator to certify a developer as ok would help you guy provide support give and take.
    Thanks wayne

  12. #12
    Nokia Developer Moderator
    Join Date
    Oct 2006
    Location
    Finland
    Posts
    4,541

    Re: Cannot deploy Phoneapp1 to my lumia 920

    Quote Originally Posted by wlab View Post
    Hello Neil, understand, wish this was displayed somewhere that is easy to see so that you and I did not have to spend time on it.
    btw what about new developers looking for answers, kind of limits their ability to explain in wordy text until get to 100 posts. Perhaps a way by the moderator to certify a developer as ok would help you guy provide support give and take.
    Thanks wayne
    Its very rare that developers try to attach. And when they do want to, more often than not (unknowingly) they would have crossed the threshold anyway.

    Certifying and evaluating each user who joins is a bigger task than writing the above post which perhaps is my first or second time only till date doing so. So you can imagine the precedence of the issue.

  13. #13
    Registered User
    Join Date
    May 2013
    Posts
    8

    Re: Cannot deploy Phoneapp1 to my lumia 920

    I would agree Neil but Nokia caused the problem. lol I only posted in text and never attached until I switched to a smart phone. I love my 920 and its just so easy to take pictures of a computer screen or whatever and keep on working. So now a picture is worth a thousand words, scratch that, a wordy text explanation. Before I would do a screen grab (hoping that software was on the computer I was using at the time) or have to write down the error msg and then retype later. So change is good.

  14. #14
    Nokia Developer Moderator
    Join Date
    Oct 2006
    Location
    Finland
    Posts
    4,541

    Re: Cannot deploy Phoneapp1 to my lumia 920

    Quote Originally Posted by wlab View Post
    I would agree Neil but Nokia caused the problem. lol I only posted in text and never attached until I switched to a smart phone. I love my 920 and its just so easy to take pictures of a computer screen or whatever and keep on working. So now a picture is worth a thousand words, scratch that, a wordy text explanation. Before I would do a screen grab (hoping that software was on the computer I was using at the time) or have to write down the error msg and then retype later. So change is good.
    Apologies that I did not understand the whole thing. I will answer whatever I understood.

    'Nokia caused problem'..because? They gave a smartphone as good as 920? I dont think you meant it..anyway..moving forward.

    Most queries that we see are by developers, who deal with codes/APIs/etc. So more often than not, even if one is not native to English, one conveys through the codes written for application. So more often than not, even if somebody isnt able to convey his/her problem by words, their code and errors tell the story. Copying codes and error messages is easy (you dont have to type really as you proclaim). Instead of screen grab, you are better off copy pasting only relevant codes rather than the whole screen. Also I accept with the terminology that picture is worth a thousand words. But as software developers, we dont deal with thousand words. When faced with issues, we deal with only relevant words (relevant lines of codes)

    Yes Change is the only constant. but change for better is what we should aim for. Your thoughts are appreciated and welcome

  15. #15
    Registered User
    Join Date
    May 2013
    Posts
    8

    Re: Cannot deploy Phoneapp1 to my lumia 920

    Neil, elegantly said !
    Wayne

Similar Threads

  1. Updates for Lumia 920, Lumia 820 and Lumia 620
    By hamishwillee in forum News and Announcements
    Replies: 0
    Last Post: 2013-03-15, 02:13
  2. NFC on WP8 Lumia 820 and 920
    By pantertom in forum Near Field Communication
    Replies: 2
    Last Post: 2012-10-01, 16:39
  3. App doesn't deploy after tombstoning on Lumia 900
    By lemieux in forum Windows Phone General
    Replies: 3
    Last Post: 2012-05-16, 12:54

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×